account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Accepted Solutions makes a difference!

Did you know that by clicking the Accept as Solution button You will help other people visiting the community to find their answer? Learn more.

Psst - What do you think about our community? Take a moment and share your thoughts around this community by doing this short survey.

no WiFi after update to ICS

SOLVED
One time poster
Message 1 of 7
2,398 Views
Message 1 of 7

no WiFi after update to ICS

Hi,

Wifi access to my home network worked very nicely under android 2.3.7. Now under 4.0.4 the phone does connect or so it tells me at the Wi-Fi tab, and it seems the phone starts connecting but the connection is blocked. I feel i've tried everything including resetting the phone and the router, the repair option in PC-companion etc. Have i missed something obvious, or less obvious. Have the rules for Wi-Fi passwords changed as that is the only option i haven't changed yet, as that would involve changing lots of logins. BTW my phone is set to dutch language. 

Regards,

Frits

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
One time poster
Message 3 of 7
2,102 Views
Message 3 of 7

Re: no WiFi after update to ICS

Try this, I had the same problem but was finally able to resolve it.

Try and change the channels of the router between 1-11(one of them will work out, hopefully 1 or 6 or 11) and the mode of the router to be 11bg mixed.

http://talk.sonymobile.com/thread/53479

View solution in original post

6 REPLIES 6
Demigod
Message 2 of 7
1,884 Views
Message 2 of 7

Re: no WiFi after update to ICS

Thanks for posting and welcome to the forum! Slightly smiling Face

First of all, check the thread on the link below for a bunch of tips when it come's to wifi issues.

http://talk.sonymobile.com/message/154244

If non of them sorts it out I'd recommend you to contact your local Sony Mobile support so they can try to help you out.

You can find contact info on the link below.

http://www.sonymobile.com/gb/support/contact-us/

What do you think about this forum? Let us know by doing this short survey.

Highlighted
One time poster
Message 3 of 7
2,103 Views
Message 3 of 7

Re: no WiFi after update to ICS

Try this, I had the same problem but was finally able to resolve it.

Try and change the channels of the router between 1-11(one of them will work out, hopefully 1 or 6 or 11) and the mode of the router to be 11bg mixed.

http://talk.sonymobile.com/thread/53479

View solution in original post

One time poster
Message 4 of 7
1,884 Views
Message 4 of 7

Re: no WiFi after update to ICS

Thank you,

your answer is correct, Unfortunately what worked was changing my router from 11bgn to 11bg. It seems that Sony doesn't like it if your WiFi is too fast. Slightly frowning Face

One time poster
Message 5 of 7
1,884 Views
Message 5 of 7

Re: no WiFi after update to ICS

I also encountered problems with WIFI after upgrading to ICS.

Sola found WIFI from D-Link DIR-615 in G/N (1-11 channels) mode with WPA\WPA2 security only after clicking several times Found button. Other phones and notebooks work fine in this mode.

But Sola works fine only in G (1-11 channels) mode with WEP security.

Router is in the most up-to-date version of frimware.

Sony, could you, please, check this issue?

One time poster
Message 6 of 7
1,884 Views
Message 6 of 7

Re: no WiFi after update to ICS

Thank you for your reply. Did you notice that in your last line the name Sony was deleted. In the mailversion i got from you it read: "Sony, could you check this issue?"

My Sola does work with my home WiFi in B/G protocol on channel 1-11 with WPA/WPA2 enabled. This is on a Fritz!Box 7340 router. I am not even going to try WEP because WEP is completely unsafe. The Sola also does not work after the ICS update on public WiFi-hotspots that logically don't have any security settings.

I am getting more convinced the problem is a faulty implementation of the N protocol in the Sola ICS update. 

I have contacted my local Sony Mobile support but that has not done much good. They tried to act like it was my individual problem. Maybe if we all contact Sony they may actually do something.   

One time poster
Message 7 of 7
1,884 Views
Message 7 of 7

Re: no WiFi after update to ICS

I edited this post Slightly smiling Face

Ok, I also try to contact with support.