account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Accepted Solutions makes a difference!

Did you know that by clicking the Accept as Solution button You will help other people visiting the community to find their answer? Learn more.

Psst - What do you think about our community? Take a moment and share your thoughts around this community by doing this short survey.

Xperia GO has no network signal(no service)

One time poster
Message 31 of 70
1,706 Views
Message 31 of 70

Re: Xperia GO has no network signal(no service)

I also have the same problem. It is losing signal when i go inside a building this does not happen on my Nokia 5800. I was trying to update the software version but it failed. I even called the Sony Support in UK for 2x but that did not help me. They just advise to use another pc

Another thing is, the phone update on the setting says i have the latest software but when i connect using the PC COMPANION it say there is a new update.

Both the PC COMPANION and SERVICE UPDATE failed on my phone! Very disappointed! It even crashed my pc several times!

I will post it once it gets it updated. Or otherwise i will return this to Amazon.de

Unregistered user
Not applicable
Message 32 of 70
1,706 Views
Message 32 of 70

Re: Xperia GO has no network signal(no service)

when updates are available for sony xperia go.... give me need full reply...

One time poster
Message 33 of 70
1,706 Views
Message 33 of 70

Re: Xperia GO has no network signal(no service)

Hi To ALL:

This is an update of my post on #30. I just updated my XPERIA GO last night to 6.0.B.3184 in connection on LOSING SIGNAL. Guess what??? The problem of losing signal is NOT SOLVED! Updating to 6.0.B.3184 would not help! Right now (while typing this post) i don't have signal on my phone!!! And if there is signal the bar goes up and down to 1 bar until nothing to see.

It looks like a hardware problem not a software! The antenna is very poor!

Another issue of this phone is the audio. If you are using viber, skype, supervoip, mobilevoip the other line would complain that the audio is so low that sounds like very "far" from the microphone. I even asked my friend to put the volume in high but still no changes. I tried it on several wi-fi but the audio still the same - very low!

I like a phone with waterproof feature but this xperia go really disappointed me! If this would not be solve. I think i will just returned this to Amazon.de

I think i will stick with my NOKIA 5800 and get a waterproof case or a zip lock rather spending money on this kind of crap! I am really disappointed!!!

SONY, WHAT ARE YOU DOING???!!!!

Unregistered user
Not applicable
Message 34 of 70
1,706 Views
Message 34 of 70

Re: Xperia GO has no network signal(no service)

Hi To ALL:

This is an update of my post on #30. I just updated my XPERIA GO last night to 6.0.B.3184 in connection on LOSING SIGNAL. Guess what??? The problem of losing signal is NOT SOLVED! Updating to 6.0.B.3184 would not help! Right now (while typing this post) i don't have signal on my phone!!! And if there is signal the bar goes up and down to 1 bar until nothing to see.

It looks like a hardware problem not a software! The antenna is very poor!

Another issue of this phone is the audio. If you are using viber, skype, supervoip, mobilevoip the other line would complain that the audio is so low that sounds like very "far" from the microphone. I even asked my friend to put the volume in high but still no changes. I tried it on several wi-fi but the audio still the same - very low!

I like a phone with waterproof feature but this xperia go really disappointed me! If this would not be solve. I think i will just complan in    consumer court.

SONY, WHAT ARE YOU DOING???!!!!

Unregistered user
Not applicable
Message 35 of 70
1,706 Views
Message 35 of 70

Re: Xperia GO has no network signal(no service)

Hi All,

Today i updated my Sony Xperia GO with the new build(6.0.B.3184).....

And I Lost everything now.....My mobile is only showing SONY on screen....

And it is not starting now......It is in Hang Mode.....i did everything to make it in running condition...but nothing works....

Advising you all....not to update latest build manually...

Go to Service Center and repair the mobile.....thats it....

Slightly frowning Face

Sony....you lost your Loyality........

 

Jay

Unregistered user
Not applicable
Message 36 of 70
1,706 Views
Message 36 of 70

Re: Xperia GO has no network signal(no service)

My problem is solved after update.

Unregistered user
Not applicable
Message 37 of 70
1,706 Views
Message 37 of 70

Re: Xperia GO has no network signal(no service)

sony xperia go update are not come in market....

Unregistered user
Not applicable
Message 38 of 70
1,706 Views
Message 38 of 70

Re: Xperia GO has no network signal(no service)

I have updated my phone to 6.0.b.3.184 on 6th August. After then I am not facing such problem.

One time poster
Message 39 of 70
1,706 Views
Message 39 of 70

Re: Xperia GO has no network signal(no service)

I am on .162, and must say that it has happened to me to loose the network and realize I'm offline hours after. Only rebooting will reconnect.

This does not happen often, but it does have happened several times.

Unregistered user
Not applicable
Message 40 of 70
1,706 Views
Message 40 of 70

Re: Xperia GO has no network signal(no service)

hi i have the newest fw and still no signal many many times only the phone not show it! that is the big fix. and the surprice is coming today to me when i try to recieve one call. here we go...Grinning Face

http://www.youtube.com/watch?v=Rh3PbZgiFaU