account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

whatsapp messages delays

SOLVED
Rookie
Message 1 of 8
8,256 Views
Message 1 of 8

whatsapp messages delays

My new phone xperia z5p has a huge problem with whatsapp message delay. I cannot receive whatsapp message normally.

 

My whatsapp Group Çase:

Friend A send a message ''what did you have for dinner?" 19:30

Friend B send a message "McDonald" 19:35

Friend A send a message "so poor" 19:38

 

My phone receive message when I turn on wifi/4G at 22:00

what did you have for dinner? 22:00

so poor  22:00

 

Keep turning on wifi/4G, next morning

McDonald  08:33

 

It is so weird that some messages are missing in the whatsapp group and the order is wrong. Even I received messages from friend A, the time is not correct. It should not be the time I check whatsapp.

 

I have tried following solution but the problem still exists.

 

Reinstall whatsapp

Reset the whole smartphone

Return on the phone by pressing ''+volume" and "turn off button" for 5 seconds.

Check no battery saving mode is turned on

Check no data restriction is applied on whatsapp or any application

Update to android 6.0 but the problem still exists

 

I wonder is it about the phone problem because the problem exists from the beginning when I used the new z5p.

 

I am really appreciated if anyone can helpSlightly frowning Face

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Demigod
Message 3 of 8
12,046 Views
Message 3 of 8

Re: whatsapp messages delays

Hi,

How often or active you are by using the phone?
I cannot confirm, but if you're not really that active using the phone.

I think the doze mode kicks in will temperary stop whatsapp from background activities. Try to go Settings > Battery Usage > upper right tap on the 3 dots > Battery Optimisation > Tap on the drop down arrow and tap All apps > look for whatsapp. Select Don't optimise.

Restart the phone, monitor it and see if this helps.
7 REPLIES 7
Inhabitant
Message 2 of 8
8,229 Views
Message 2 of 8

Re: whatsapp messages delays

Check out the thread about WiFi turning off. Could be related
Highlighted
Demigod
Message 3 of 8
12,047 Views
Message 3 of 8

Re: whatsapp messages delays

Hi,

How often or active you are by using the phone?
I cannot confirm, but if you're not really that active using the phone.

I think the doze mode kicks in will temperary stop whatsapp from background activities. Try to go Settings > Battery Usage > upper right tap on the 3 dots > Battery Optimisation > Tap on the drop down arrow and tap All apps > look for whatsapp. Select Don't optimise.

Restart the phone, monitor it and see if this helps.
Adviser
Message 4 of 8
8,181 Views
Message 4 of 8

Re: whatsapp messages delays

Hi KlausLai,

If you are using MM 6.0 than you can remove whatsapp from battery saving settings.

Steps:
Settings > Battery usage > Battery optimization (3 dots on top right) > tap on all apps > select whatsapp > choose option not to optimize.

That's it.

If on LP
Add whatsapp in stamina mode.

Hope that helped.
Rookie
Message 5 of 8
8,144 Views
Message 5 of 8

Re: whatsapp messages delays

Thank you so much for your reply. I guess it works.

Adviser
Message 6 of 8
8,133 Views
Message 6 of 8

Re: whatsapp messages delays

Welcome, in case it didn't worked let us know.
Take care
One time poster
Message 7 of 8
7,934 Views
Message 7 of 8

Re: whatsapp messages delays

Hi,

I already disabled the battery optimization for whatsapp but still have the problem that I do not receive messages when I've been idle for a while. I only get the messages when I open whatsapp as if the battery saving mode is turned on.

Regards,

Fabian

One time poster
Message 8 of 8
7,268 Views
Message 8 of 8

Re: whatsapp messages delays

Hi!

I don´t know if this helps, but with xperia XZ I had to add the apps I wanted to be active to the list of apps in data saver, then whatsapp messages started to arrive right away.