account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Z5 Compact unable to read sims.

One time poster
Message 1 of 3
1,012 Views
Message 1 of 3

Z5 Compact unable to read sims.

Z5 Compact unable to read sims.

2 REPLIES 2
Highlighted
Sony Xperia Support
Message 2 of 3
948 Views
Message 2 of 3

Re: Z5 Compact unable to read sims.

Hi @SCOTLAND1, sorry to hear about this. Slightly frowning Face

To start with, make sure that you have inserted the SIM card correctly with the SIM card holder as shown on the link below.

https://support.sonymobile.com/global-en/xperiaz5compact/userguide/assembly/

If you have inserted it correctly and it's still doesn't read the SIM cards that you have tried with, the next step is to perform a software repair using Xperia Companion. This will delete all data stored on the internal storage of the device, so it's important that you create a backup with the same program in case you have information that you want to save.

Let me know if that helps!


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

One time poster
Message 3 of 3
943 Views
Message 3 of 3

Re: Z5 Compact unable to read sims.

I have tried with several sims to no avail plus the system repair on my laptop is failing to work even after deleting and reinstalling the Sony Companion several times.