account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Wifi doesn't connect while phone is in sleep

SOLVED
Adviser
Message 111 of 166
1,238 Views
Message 111 of 166

Re: Wifi doesn't connect while phone is in sleep

It's easy to repdoduce, that's why so many of us are complaining (in a calm and measured maner in my case).  I've used up my data plan for the month again prematurely, something that I never used to have an issue with.  I wonder why...

Regular
Message 112 of 166
1,176 Views
Message 112 of 166

Re: Wifi doesn't connect while phone is in sleep

malmostoso,

 

The app Wifi Keep Alive just fixes a part of the bug.

The reconnection to a in range wifi signal is still there. So the phone doesn't connect to a wifi signal automatically when the phone is in sleep/ display off.

This issue is simple to reproduce,  just walk away so the phone loses the wifi signal an walk back. After a couple of seconds I unlock the phone and see it hasn't any wifi connection. Just after 1-2 secs it makes the connection, because I unlocked the phone.

Regular
Message 113 of 166
1,138 Views
Message 113 of 166

Re: Wifi doesn't connect while phone is in sleep

Hmm interesting.

 

It seems to work for me, as soon as I come home I turn the screen on and the wifi is already connected. Maybe having the phone in my pocket does not make it "sleep" so deeply? I remember doze working like that (or maybe it was stamina, I'm not sure).

 

I think as soon as I receive the newest update I'll try with another factory reset to see whether it might be a settings problem, however after having tested safe mode and noticing the bug there as well I don't have high hopes.

Inhabitant
Message 114 of 166
1,122 Views
Message 114 of 166

Re: Wifi doesn't connect while phone is in sleep

I tried the app malmostoso has recommended. But it does not work with my Z5c (although I put the app in the exception list to keep alive in standby). Although WIFI seems to be active also without that app all the time (as soon as I activate the screen the WIFI symbol is already present), there is no communication and no auto sync in standby on WIFI.

 

As soon as I don't touch the phone for 15 minutes it does not receive any GMAIL or EAS mails anymore (it does not synchronise anymore). But only when I am connected to WIFI and not when connected by mobile data. This happens also in safe mode.

 

Any settings tested hundret times in all possible combinations. I also tried several different apps (push notification fixer, WIFIkeepAlive, and some more). Additonally I exchanged my WIFI router.

Only thing I did not proceed so far is a complete reset of the Z5c to factory settings. I have not heard that this bug was solved by anybody with a factory reset. Or can anybody confirm the problem was solved by a factory reset?

 

Are there any other workarounds for this issue? It seems that not any phone is affected, otherwise this thread would be much longer.

Why are only some phones affected? Is it dependent of the WIFI router, customisation, hardware, certain settings, etc.?

Has Sony ever given any statement about this issue?

 

Thanks for any useful hint in advance.

 

Inhabitant
Message 115 of 166
1,079 Views
Message 115 of 166

Re: Wifi doesn't connect while phone is in sleep

Yesterday I made a software repair and factory reset with PC Companion but also after that the problem is still there.

 

Additionally I found that exchange active sync does sometimes also not receive emails in active state. Also in case I use the phone (screen on) the mails do not arrive when on WIFI. On other phones or tablets they arrive immediately which means the server works correctly. Also when on mobile data they are received on my Z5c on time but on WIFI they are delayed for undefined time. So this is not only a standby issue.


Any ideas?

Highlighted
Sony Xperia Support
Message 116 of 166
2,647 Views
Message 116 of 166

Re: Wifi doesn't connect while phone is in sleep

In the latest update, 32.2.A.0.224, we have enabled background scanning for WiFi so your phone will (re)connect after being out of range even when it's in sleep. It might take up to 5 minutes or so before it connects when in sleep though.

 

If your WiFi still doesn't work properly after this update, if possible, please try your phone with another router/access point to make sure this is not caused by the router/accesspoint.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

View solution in original post

Inhabitant
Message 117 of 166
1,010 Views
Message 117 of 166

Re: Wifi doesn't connect while phone is in sleep

Hmm Rickard, are you all misunderstanding the problem, or is this a fix for just one of them?

 

The problem the most of us seem to have here is the Wi-fi cutting off WITHOUT going out of range.

 

I'm sat here in my room, switch the screen off, switch it back on after a few mins and the wi-fi is disconnected, and re-connects when I wake it.

 

It has NOT been out of range of my router at any time during that.

Inhabitant
Message 118 of 166
992 Views
Message 118 of 166

Re: Wifi doesn't connect while phone is in sleep

Hello Rickard,

 

Thanks for your kind response. I very much appreciate that someone from Sony takes care about this. But I agree with the feedback from BobT. Unfortunately the problem is not fully understood by Sony so far. Please let me try to describe once again what many users experience.

 

It is not a re-connection problem when entering a known WIFI area but what we complain is a problem when staying in the WIFI area. Just after some minutes in standby the phone does not notify about any new messages anymore (except SMS).

 

-I just use standard apps like the original email app from Sony or the Gmail app.

-When connected to WIFI and the phone is next to the router (without leaving that area) the phone does not recognise any push notifications (EAS push mail, Gmail) anymore after some minutes not using the phone (i.e. after 15-30 minutes).

-That means I lay down the phone, wait 15-30 minutes and send from my computer an email to my Gmail or Exchange Active Sync email addresses and my Z5c does not notify me about those new emails. I have the same email accounts installed additionally on two older phones (Xperia Neo and Xperia Acro S) and on those phones the mails arrive immediately. But unfortunately not on the Z5c. On the Z5c they arrive at undefined time (many minutes or much longer time later, sometimes also immediately when in standby for i.e. 5 minutes only). This seems to be totally randomly.

-When I activate the screen on my Z5c the WIFI symbol is still present from beginning. Sometimes push notifications arrive just after activation of the screen. Sometimes they also do not arrive then. This seems to be also randomly. When I manually check for new emails they arrive.

 

When not connected to WIFI but to mobile data all push notifications seems to work normally - also in standby.

 

For me it seems parts of the phone are sleeping when the screen is not active with WIFI connection.

-although STAMINA is not activated (it is switched off)

-although the email apps and exchange servcies apps are added to the white list (no battery optimisation for those apps)

-although WIFI is set to stay always active in standby and WIFI is continuously in range (phone 2 meter next to the WIFI router)

-although Auto Sync is switched on

-although the latest update 32.2.A.0.224 is installed

-although background data are not limited

 

To solve that problem I tried already anything possible in my point of view.

-I did reset all email accounts and set them up again

-I did reset the Z5c to factory settings and made a software repair two times

-I tested it just after the factory reset without installing anything additional on the phone except the email account

-I tested the phone in safe mode

-I tested it with several different Gmail addresses and EAS accounts (company account, outlook.com, etc.)

-I even exchanged my WIFI router to an other brand

-I tested some additional apps to fix the problem (Push Notification Fixer, Wake Lock PowerManager, WIFI Keep Alive, etc.)

-I tested all possible settings on the phone and this problem seems to be NOT influenced by any WIFI settings, STAMINA settings, battery optimisation settings (Doze), or additional apps

-I also set the email apps for testing to 5 minutes instead to push and this does not work as well. In standby the emails are also not received when set the time to "every 5 minutes". In standby the phone does not check the mails every 5 minutes but only at any randomly time later.

 

All this did not help and the problem is still present. The problem was already present with Android 5.1.1 on the Z5c.

 

Since older Xperia phones work correctly on the same WIFI router and with exactly the same email accounts I am sure it is a problem of the Z5c itself. Some messaging parts in the phone seems to be not active when not using the phone for few minutes although connected to WIFI continuously. I am not sure if it is a software or even a hardware issue.

 

Please tell me how I can support you to reproduce this problem and what you need from me? Is there a way that I send you directly some log files from the phone which might help you to reproduce the problem and find a solution for this?

 

Many thanks for your support.

One time poster
Message 119 of 166
977 Views
Message 119 of 166

Re: Wifi doesn't connect while phone is in sleep

Hi, 

 

I have the same problem with my Z5 Premium

 

When you are connected to a wifi router and you put your phone on standby mode (screen off ) , wifi disconnect alone after a period of 5 or 10 minutes , so at this moment you are not inform if you receive email or all other internet notifications. 

 

To reconnect wifi , you must switch standby mode to on and wifi reconnect to the router without any interaction of user.

 

at this moment i don't find any solution to keep wifi alive always on standby.

 

?????

Sony Xperia Support
Message 120 of 166
973 Views
Message 120 of 166

Re: Wifi doesn't connect while phone is in sleep

@BobT @Dihi

I'm sorry to hear that your phone disconnects even though in range and you don't have push Slightly frowning Face

My reply was in regard to the topic, "Wifi doesn't connect while is in sleep", and what big_o reported in the first post of the topic.

With previous versions of the software, the phone would not connect automatically to saved networks while in sleep, this has now been changed with the latest version. So now when you for example come home, the phone will automatically connect to your WiFi within a few minutes without you needing to turn on the display.

What you are describing is not related to this. I think what you both are seeing deserves their own topics to avoid mixing different concerns in one thread.

But if you haven't already, i recommend that you check these things first:

Make sure that "Keep Wi-Fi on during sleep" is set to "Always"

Try safe mode to make sure you don't have an app causing it.

Try the phone with another access point or router to make sure it's not caused by the router/access point.

Update the firmware in your router/access point

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.