account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Wi-fi - Internet problem

SOLVED
Highlighted
Regular
Message 1 of 7
980 Views
Message 1 of 7

Wi-fi - Internet problem

Wi.png

 

I get the above icon every so often on my z5 Premium. I have looked through the user manual, checked all my Internet/mms settings - downloaded the config file. If I turn off my wi-fi connection and then turn it on again the exclamation mark disappears and all is well until, after an indeterminate time , perhaps just 5 minutes, the ex mark appears again. Am I missing a setting on the 'phone? The 'phone reports the wi-fi connection as 'excellent', 144 mbs even when the exc mark is displayed. Any thoughts?

 

Jeff

1 ACCEPTED SOLUTION

Accepted Solutions
Scavenger Hunt Winner
Message 2 of 7
1,678 Views
Message 2 of 7

Re: Wi-fi - Internet problem

Do you know how to setup a static IP on your phone? If you do, try a static IP, if your router is adamant on keeping DHCP, you can set the IP from the router using the phones MAC address

 

If you don't know what I'm talking about, let me know and I can type a bigger wall of text explaining an avenue to try

//----------------- C:\》$ Path- Thyme: .trawler //-----------------Auto-Correct Disclaimer: Not sorry. //----------------- Batteries not included.
6 REPLIES 6
Scavenger Hunt Winner
Message 2 of 7
1,679 Views
Message 2 of 7

Re: Wi-fi - Internet problem

Do you know how to setup a static IP on your phone? If you do, try a static IP, if your router is adamant on keeping DHCP, you can set the IP from the router using the phones MAC address

 

If you don't know what I'm talking about, let me know and I can type a bigger wall of text explaining an avenue to try

//----------------- C:\》$ Path- Thyme: .trawler //-----------------Auto-Correct Disclaimer: Not sorry. //----------------- Batteries not included.
Regular
Message 3 of 7
961 Views
Message 3 of 7

Re: Wi-fi - Internet problem

Thanks for the reply, I do understand your suggestion, was hoping it was a simple setting I'd missed before I start delving. I'll post if I get it stable.

Jeff
Scavenger Hunt Winner
Message 4 of 7
954 Views
Message 4 of 7

Re: Wi-fi - Internet problem

I don't trust automatic things anymore... especially when Windows tries to change drivers that end up changing the voltages for my chip... so when I go fault finding things, I usually set things to a known value.

 

Sometimes I hate electronics.

 

 

EDIT: Also - just saw this:
http://talk.sonymobile.com/t5/Xperia-Z5-Z5-Compact-Z5-Premium/quot-Google-Play-Store-has-Stopped-quo...

 

From memory, that exclamation mark also triggers when the phone can't connect to android services... I'm not sure if it's still the same now - and if it's the same for each manufacturer.

 

You may be slightly luckier and it may not be crashing your Play Store - but there may be something going on that we can't see

//----------------- C:\》$ Path- Thyme: .trawler //-----------------Auto-Correct Disclaimer: Not sorry. //----------------- Batteries not included.
Regular
Message 5 of 7
610 Views
Message 5 of 7

Re: Wi-fi - Internet problem

Adviser
Message 6 of 7
454 Views
Message 6 of 7

Re: Wi-fi - Internet problem

Would you mind copying what worked for you? I quickly read through the 10 pages of that thread and didn't see an obvious resolution. I am having the same problem. Thank you.

Enthusiast
Message 7 of 7
405 Views
Message 7 of 7

Re: Wi-fi - Internet problem

How did you fix it?