account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

WIFI drops connection on z5 premium.

Highlighted
Regular
Message 61 of 193
1,973 Views
Message 61 of 193

Re: WIFI issues on z5 premium.

Wow ... this IS disappointing in the extreme ... sooo many people (and sadly I am one of them) having the same WiFi problem, and on a top of the range mobile that costs as much as an excellently specced laptop.

 

My previous phone - an HTC ONE SV connected flawlessly, consistently and constantly to my WiFi. My Z5 connects (reportedly @ 144 mbs) for a short while then displays the ! over the WiFi icon as detailed by so many disappointed owners previously in this thread and then refuses to connect to the internet. With WiFi turned OFF the 4G connection is excellent. So this must be a Z5 WiFi problem.

 

SONY - its your responsibility to sell items which are FIT FOR PURPOSE. I love the Z5, in all respects bar its WiFi connectivity which is frankly appalling. YOU need to get this sorted, otherwise this handset is NOT FIT FOR PURPOSE. 

 

We pay the money for a premium device and end up with less than good performance ... the ball is decidedly in YOUR COURT SONY ... what are you going to do about this?

Regular
Message 62 of 193
1,939 Views
Message 62 of 193

Re: WIFI issues on z5 premium.

An update - I have scoured the forums for help with this issue, and though I tried the following earlier with no success I repeated it and seem to have got somewhere;

 

I unplugged my router/Hub and left it for 5 minutes. I went into the WiFi settings on my 'phone and told it to forget my Hub and then turned off the 'phone for 5 minutes.

 

I re-powered my Hub/router, and did the same with the 'phone. It 'found' my Hub, and asked for the p'word, after entering p'word the 'phone connected to my Hub/router and (2 hours later) I haven't experienced an Internet drop or the ! on the WiFi icon.

 

I hope this has fixed this issue as I love the 'phone - but having seriously fragile WiFi/Internet connection will REALLY spoil it for me Slightly frowning Face

 

Fingers crossed!

 

Jeff

Regular
Message 63 of 193
1,830 Views
Message 63 of 193

Re: WIFI issues on z5 premium.

A final update... sadly the solution I added in my previous post lasted about 2 hours before my z5p lost Internet connection. However I changed my BT hub from v3.0 to v5.0 - the result; since the new hub scans the mobile for best connection settings it has set the connection to 5GHz whereas my old hub only supported 2.5Ghz. Since connecting my z5 the 'phone has behaved flawlessly, currently reporting a speed of 844 Mbs. My recommendation, if anyone is having this problem, is to change the wifi connection frequency to 5Ghz.

Relieved Jeff Slightly smiling Face
Adviser
Message 64 of 193
1,682 Views
Message 64 of 193

Re: WIFI issues on z5 premium.

Is this the final solution?
One time poster
Message 65 of 193
1,670 Views
Message 65 of 193

Re: WIFI issues on z5 premium.

Yes I'm also one of the victims with the Z5 Premium.

 

Final solution is to switch to a brand that makes working smartphones. And make every potential customer/victim aware of this before they make a mistake.

Adviser
Message 66 of 193
1,654 Views
Message 66 of 193

Re: WIFI issues on z5 premium.

Did someone took the Phone to Sony store?
Regular
Message 67 of 193
1,641 Views
Message 67 of 193

Re: WIFI issues on z5 premium.

Same issues on my z5p tried everything turning Bluetooth off n on removing sd card reinstalling the newest update to the phone and nothing works yet a tablet I bought for my son from some cheap Chinese website works perfect for and never has any issue, so I'm currently waiting for the phone to be repaired by Sony
Adviser
Message 68 of 193
1,606 Views
Message 68 of 193

Re: WIFI issues on z5 premium.

I think the real problem is that z5 lacks WiFi range. Thats why it drops connection and has very low transfer data speed. Sony needs to make an update giving more power to the WiFi antena.
Message 69 of 193
1,580 Views
Message 69 of 193

Re: WIFI issues on z5 premium.

I had the same problem on my Sony Experia Z5 Premium and I managed to resolve it in less than five minute. The solution might not be generic as there is a variety of WI-FI routers out there. To be specific I am on NETGEAR router with a WPS button. Follow the following steps if your router has the WPS button I am very positive that the problem will be resolved.

 

1. Go into settings

2. On Wireless & networks select the WI-FI option

3. Ensure the WI-FI button is on

4. On the top right corner click the three dots

5. From the drop down menu select Advanced

6. Select WPS Push Button

7. Press the WPS Button on your router until orange light starts blinking

8. Once your phone is connected the light colour changes to green

9. If connection fails repeat the process from step 7

 

I hope this will help you to resolve the WI-FI issues. Alternatively WPS PIN Entry can be used to connect the device to the router.

Adviser
Message 70 of 193
1,570 Views
Message 70 of 193

Re: WIFI issues on z5 premium.

have a WiFi extensor that is netgear I think, but my main router its Zhone.