account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

WIFI drops connection on z5 premium.

Sony Xperia Support
Message 21 of 193
4,323 Views
Message 21 of 193

Re: WIFI issues on z5 premium.

If the option "Take bug report" is greyed out, please make sure that you have enabled "USB debugging".

When you select "Take bug report", it may also take a little while for the phone to create the log. When it's done you get a notification in the notification bar that you tap and share to Google Drive.

But please make sure you also have "Enable Wi-Fi Verbose Logging" enabled.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Message 22 of 193
4,276 Views
Message 22 of 193

Re: WIFI issues on z5 premium.

Ok, new update on the issue - the wifi and the mobile data are gone in the first 10-20 seconds after I unlock the phone. After that it is all fine... In locked mode of course no wifi or mobile data is available and I do not get notifications while phone is locked... Way to go Sony... I will now try the logs as mentioned above!

Inhabitant
Message 23 of 193
4,245 Views
Message 23 of 193

Re: WIFI issues on z5 premium.

Another update.

It seems to be three different errors.

First of all, as mentioned, The wifi takes 15-30sec to "wake" after unlocking phone wich makes it unuseable during that time.

 

Secondly, The exclamation mark comes randomly, and wifi stops working. A restart of wifi then helps. Sometimes it resumes wifi by its own.

 

Third, no matter what setting i use in  "wifi/advanced/keep wifi in resting mode" it seems NOT to keep wifi. For example:when i check phone first thing in the morning, regardless off setting, I get all my notifications when i start phone, so wifi has been off and not recieving any thing during night even if ive choosen "Wifi never sleep". Although this is not 100% either.

 

Something is very fishy with the wifi on this phone.

I will send Rickard, yet another bug report from this morning.

 

/Gunnar

Visitor
Message 24 of 193
4,181 Views
Message 24 of 193

Re: WIFI issues on z5 premium.

My z5 premium WiFi is hopeless.  Drops out all the time. My mobile just keeps buffering and do anything over WiFi. Love the phone but can't use it. Can't stream tune in radio WiFi is Crap. Even at full signal. 

Emperor
Message 25 of 193
4,174 Views
Message 25 of 193

Re: WIFI issues on z5 premium.

@Bla_bla

 

My Z5 Premium works fine, and I've been using a LOT, and when I say a lot, I mean, quite a bit of different routers and it has been working fine. 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Sony Xperia Support
Message 26 of 193
4,136 Views
Message 26 of 193

Re: WIFI issues on z5 premium.

@ronaldinho161 @gundeho

It sounds like you may have "Extended standby" and "STAMINA clock" enabled under Settings -> Power management -> STAMINA mode. In this case, the phone will turn off WiFi and mobile data when you're not using the phone. There will also be a delay before they're connected again when you turn on the display. The delay will be minimized in future software updates but if you want to keep WiFi connected when not using the phone, you need to turn these off.

 

 

When WiFi stops working while you are using the phone, could you please try if this also happens if you set the phone in airplane mode?

If it also happens in airplane mode, could you try if it happens in safe mode?

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Highlighted
Inhabitant
Message 27 of 193
4,075 Views
Message 27 of 193

Re: WIFI issues on z5 premium.

My latest msg. to Dear Rickard

Further then this, I also noticed that the WiFi stopping in the middle of browsing/facebooking and so on, has been MUCH better when turning off Stamina mode.

So it seems to be Staminamode up the Wifi regardless if "extended mode" is on or not!

 

Hello.

 

Sorry about delayed answer.

I can absolutely confirm that the logs were taken right after the WIFI problem occured.

 

I have also been testing around alot with the settings, and i think I pinpointed the problem.

I seems to have to do with the Stamina mode.

When the "extended standby" is enabled, the problem occurs frequently. When off, almost never.

 

Granted, the "extended standby" shuts of wifi, but the problem remains after "waking up" the phone, and as said before, alot of problems connected to it since its a) takens 20-30sec to connect, b) doesnt connect at all, and I have to restart wifi.

 

after all this time I have now shut of Stamina mode, and the phone works just fine, even though the battery performance has been reduced significantly :-(

 

br

/Gunnar

Apprentice
Message 28 of 193
4,015 Views
Message 28 of 193

Re: WIFI issues on z5 premium.

My WiFi signal is weak. I have 3 other devices that have no problems but the Z5 premium just can't be used on WiFi in the bedroom. Any help? I have just factory reset and I'm using latest firmware downloaded from Sony support tool.
Visitor
Message 29 of 193
4,009 Views
Message 29 of 193

Re: WIFI issues on z5 premium.

Same here bro, really dissapointed. Wifi drops as you described.even  2 meters from router. IN house there are 6 different devices, problems onlyu with Xperia Z5 premium. Phone bought in Sweden.

One time poster
Message 30 of 193
3,932 Views
Message 30 of 193

Re: WIFI issues on z5 premium.

Hi,

First time in Sony site, sorry if i make mistake Slightly smiling Face

I have also same problem!

 

Bought Z5 Dual in Dubai, using in Central Asia. Phone is perfect for me, I am a die hard Sony fan. Using Sony devices and mobiles last 10+ years. I have ADSL connection at home through linksys wag120N. Wifi of other phones including wifes Z1 works perfectly but not on my Z5 dual. First 2 month couldnt connect at all, no wifi logo/sign. It just says that connecting/obtaining IP for fraction of second then it saves, thats all. 3 days ago it connect magicly for 15-20 seconds and it dropped. i have tried everything like different channels on router, airplane mode thing, dhcp and so on. Thought maybe router and z5 had  connection issue but in the end tried TP-link wifi adapter (SOFTAP). Same applies here, Z1 connecting perfectly to Softap, Z5 connects, internet is working but after 10-15 seconds dropping despite wifi sign/logo is still there. I have to forget and reconnect and it will disconnect one more time in 10-15 seconds. It is unbelievably annoying, dont know what to do. And as i said as i bought it from Dubai i do not have chance to change it despite all guarantee documents are available. I really hope you have some abra-cadabra thing to fix it Slightly smiling Face

P.S. Not using any Stamina mode!

Thanks.