account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

WIFI drops connection on z5 premium.

Inhabitant
Message 1 of 193
19,791 Views
Message 1 of 193

WIFI drops connection on z5 premium.

My Z5P  drops wifi constantly. Looses contact, everywhere. In 5min it can happen 3-5times.

While no one else with for example Iphone looses.

It also happens frequently in public wifi places, and its really annoying.

 

Anyone else with the same problem?

I am ready to return phone. Its THAT bad!

 

Topic edited by Rickard

192 REPLIES 192
Highlighted
Sony Xperia Support
Message 2 of 193
19,779 Views
Message 2 of 193

Re: WIFI issues on z5 premium.

I'm sorry to hear that Slightly frowning Face

 

Does this happen also when there's good reception and you are using the phone (display on)?

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Inhabitant
Message 3 of 193
19,775 Views
Message 3 of 193

Re: WIFI issues on z5 premium.

Hej.

 

Yes it happens Always! At home i Have 2 Asus routers (1000Mbit fiber) and full reception, and it happens when screen is on, when im sitting surfing, facebooking or wordfeuding. Suddenly i get an exclamation mark over the wifi bar, and i have to turn off and then on the wifi to get it to work again.

And it is not one or two times, It happens constantly.. EXTREMELY ANNOYING. :-(

 

Mvh

/Gunnar

Sony Xperia Support
Message 4 of 193
19,755 Views
Message 4 of 193

Re: WIFI issues on z5 premium.

When this happens, are you able to reach the configuration page of the router using Chrome? It's probably 192.168.0.1 or 192.168.1.1.

Could you also try to turn one of the routers off and see if it still happens? If you have the DHCP-server on in both, this could be the cause.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Inhabitant
Message 5 of 193
19,750 Views
Message 5 of 193

Re: WIFI issues on z5 premium.

Yes ofcourse i can reach configuration on routers. And i am obviously not using both at same time. Since my house is quite large i have one network on each floor.

And the problem occurs also at work, and public wifi, as soon as i turn off the wifi, 4G works excellent.

I clearly seems to be something wrong with Xperias Wifi. Or can it have to do with batterysaving?

Sony Xperia Support
Message 6 of 193
19,729 Views
Message 6 of 193

Re: WIFI issues on z5 premium.

 

Sorry, i meant to write Chrome in your phone. When you have the exclamation mark on the WiFi-symbol and internet in the phone is not working, are you able to reach the router configuration if you go to the router IP from Chrome in the phone?

 

What you are describing is not related to battery saving when it happens while you have the display on. It sounds like you still are connected to WiFi but the connection stops working for some reason. The exclamation mark is displayed when Android is unable to reach the Google servers.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

One time poster
Message 7 of 193
19,662 Views
Message 7 of 193

Re: WIFI issues on z5 premium.

My phone is a Z5 having similar problems unable to resolve even I called service canter. They blame on Android 5.1 version and Sony staff admitted alot of same complaint still pending to resolve
Sony Xperia Support
Message 8 of 193
19,606 Views
Message 8 of 193

Re: WIFI issues on z5 premium.

@Robinhood1

Do you see the same thing that gundeho does? That it works for a while and then displays an exclamation mark?

 

@gundeho

 

I've tried my Z5 Premium with two different Asus routers but i don't see this.
Would it be possible for you to try to do a software repair using PC Companion?

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Inhabitant
Message 9 of 193
19,604 Views
Message 9 of 193

Re: WIFI issues on z5 premium.

I have now tried different solutions here at home, and it seems the problem is most accurant when you "change" wifi.

For example, when i com from my car (with wifi) it seems like Z5p cant get on home wifi. i have to restart the wifi in the phone and then it works.

After a while for example facebooking, FB doesnt load anymore, and a few seconds after that the exclamation mark appears. And i have to restart wifi on phone.

Same happens at work. and at public wifi´s (Telia here in Sweden).

 

/Gunnar

Sony Xperia Support
Message 10 of 193
19,599 Views
Message 10 of 193

Re: WIFI issues on z5 premium.

@gundeho

I'm afraid it sounds like there's something wrong with your phone as this happens with different networks.

Would it be possible for you to try to reinstall the phones firmware by doing a software repair using PC Companion and see if that helps?

 

The phone should connect automatically if you turn on the display when you're home. Z5 will however not scan for and connect to WiFi networks automatically when it's in sleep mode (display off) so when you turn on the display, it might take a short while before you see the WiFi-icon.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.