account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

No sound from media apps in headphones

Visitor
Message 4 of 26
5,954 Views
Message 4 of 26

No sound from media apps in headphones

Hello,

 

I bought an Xperia Z5 almost a week ago, and I'm very happy with it.

The first day or so, it worked perfectly fine. Now however I'm not getting any sound from media apps in my headphones.

I've tried Youtube, Netflix, Spotify and the preinstalled media apps such as Movie and Album.

Also tried with another set of headphones, still nothing.

I can hear keytaps, ringtones and selection sounds though.

Without the headphones everything works fine.

 

Is there a setting I might have missed somehow?

25 REPLIES 25
One time poster
Message 1 of 26
5,964 Views
Message 1 of 26

Headphones not working

Xperia Z5 is not playing the sound through the headphones given with it, phone is detecting it but not playing sound through them, instead still playing through the speakers, pls help
Sony Xperia Support
Message 2 of 26
5,961 Views
Message 2 of 26

Re: Headphones not working

Hi @zaneali,


Welcome to the community.

 

Does this happen with any other headphones?


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Adept
Message 3 of 26
5,939 Views
Message 3 of 26

Re: Headphones not working

something is going wrong with MM and 3.5jack device detection... most probably detection using ohm resistance is messed up! headphones not working, line out issues...hmm...

Sony Xperia Support
Message 5 of 26
5,900 Views
Message 5 of 26

Re: No sound from media apps in headphones

Hi @HenrikE,

 

First of all, when you have a headset connected, can you go to Settings > Sound & notification and make sure that Media volume is turned up?

Could you also test your phone in safe mode and see if you still get no sound in the Music or Album app?

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Visitor
Message 6 of 26
5,887 Views
Message 6 of 26

Re: No sound from media apps in headphones

Thanks for the quick answer, but I'm afraid neither solution worked for me.

 

I have checked the volume settings in the Settings both with and without my headphones, and all volumes are turned up to max.

 

I did restart in Safe mode, but I'm still not getting any sound from the preinstalled app Album.

Adept
Message 7 of 26
5,870 Views
Message 7 of 26

Re: No sound from media apps in headphones

The phone jack is broken common problem that song are ignoring as usual. I downloaded soundabout from the app store and use that to force sound to the jack. Its a temperamental workaround
One time poster
Message 8 of 26
5,866 Views
Message 8 of 26

Re: No sound from media apps in headphones

I have been having a similar issue for the last week or so.  The phone doesn't recognise the headphones are connected so the radio won't work.  I can force my Spotify through the soundabout app so don't think the Headphone Jack is faulty.

 

I've done the android update and a phone repair through PC Companion.  Any ideas?

Apprentice
Message 9 of 26
5,839 Views
Message 9 of 26

Re: No sound from media apps in headphones

I also have the exact same problem as @HenrikE. I can hear keytaps, also the radio is working fine. The odd part is, it is working with spotify and facebook app once and then suddenly after some days, it is not working at all. Some people thinks that this is a harware problem but it's not.

 

Please relay this to the higher ups. Thanks.

Visitor
Message 10 of 26
5,786 Views
Message 10 of 26

Re: No sound from media apps in headphones

Just wanted to add that I tried with bluetooth earbuds, and they're working perfectly fine.

At the moment I have literally no idea what's causing this issue. 

As I can hear keytaps in my wired headphones, I can't really believe it's a hardware issue, but as the media is playing through bluetooth, I don't think it's an app stopping media playing either.