account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

New Z5 will not update to 7.1.1 or software repair to update

Rookie
Message 1 of 3
288 Views
Message 1 of 3

New Z5 will not update to 7.1.1 or software repair to update

 

 

I have last week purchased a brand new Sony Xperia Z5 Compact (I know, late to the party, but I wanted a small phone) and am having problems with software update. The update downloads but will not install and I am getting repeated messages that an update is due – when I try to install (full battery, stable wi-fi etc.) I am told the update could not be installed.

 

I have installed Xperia Companion on my pc and tried to update this route. It initially tells me ‘Your Xperia is already running the latest software available’.

 

I have therefore run the software repair option. This also ends up the error message

'Software repair error. An error occurred while repairing your device'

 Error info: UEGetPhoneInfoMissingInfo

 

I have factory reset the phone and retried all with the same error messages. The difference this time being that when I try and install the update from the phone, the phone is off for only a very short time, less than a minute, before coming back to tell me the update has failed whereas before it was taking a sensible amount of time to at least try and install. I have tried to clear data in the software update app as advised.

 

Returning to try and update through Companion I am using the Sony supplied cable; ensuring all other programs are closed whilst running the repair; I have tried uninstalling and reinstalling Companion; tried using Companion installed on a different computer but to no avail.

 

On the second computer the error message is also 'Software repair error' but the error ref is UEStartNoMorePorts

 

  • Model no: E5823
  • Android version: 7.0
  • Android security patch level: 1 March 2017
  • Build number: 32.3.A.2.33
  • Software version: 32.3.A.2.33

If any other info required let me know

 

It would be great to know how to fix this, I don;t want to give up on the phone yet as there are a lot of things I like about it but it is very frustrating with a new phone

 

Thanks

2 REPLIES 2
Highlighted
Emperor
Message 2 of 3
275 Views
Message 2 of 3

Re: New Z5 will not update to 7.1.1 or software repair to update

@HLB1 

 

That's rather odd, what if you update JAVA 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Rookie
Message 3 of 3
261 Views
Message 3 of 3

Re: New Z5 will not update to 7.1.1 or software repair to update

Thank you for your advice

 

I updated Java after uninstalling all old versions, then uninstalled and reinstalled Companion again

 

I am getting the same messages ie Software Update - your phone is up to date and Software Repair - error, an error occurred whilst repairing your device with the same code UEGetPhoneInfoMissingInfo

 

The difference now is that the device itself turns off as soon as Software Repair launches 

 

I therefore tried the device off route where you cannot switch on the device holding the volume down key and then connecting whilst switched off but receive the same error message

 

I understand there are a few issues for z5 users with 7.1.1 so wouldn't mind not installing it, if there was a way to switch off the endless notifications about an update

 

Thank you for responding