account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

My power button, volume button, and shutter button sometime doesn't work

SOLVED
Message 61 of 69
521 Views
Message 61 of 69

Re: My power button, volume button, and shutter button sometime doesn't work

I've fixed my phone by opening up the back of the case. My case is still open. I'll snap some pictures of the faulty plug with some measurements of the precise location if that's helpful for you guys .

Shameless Sony Fanboy
But I'm starting to lose my faith
One time poster
Message 62 of 69
506 Views
Message 62 of 69

Re: My power button, volume button, and shutter button sometime doesn't work

That would be super. My phone buttons stopped working today so I thought I would let the battery run out to reset it. Now I can't turn it back on. I'm a Sony fan but this phone has been trouble from the start. Had Z3, Z1 and even the X10i before this one. Tried squeezing it a little bit but I'm not sure exactly where and how hard to squeeze. Thanks everyone.

One time poster
Message 63 of 69
445 Views
Message 63 of 69

Re: Power, Volume, Camera buttons, and vibration not working

Same as me, I dropped 30cm to the floor. All side buttons don't work. I also used two taps to open the screen, and now I accidentally shut it down. And I don't know how to turn it back on

One time poster
Message 64 of 69
425 Views
Message 64 of 69

Re: My power button, volume button, and shutter button sometime doesn't work

you are greeeaaaaat maaaaan thank you a loooooot I cant believe its worked thanks for your help Grinning Face

One time poster
Message 65 of 69
328 Views
Message 65 of 69

Re: My power button, volume button, and shutter button sometime doesn't work

I dropped my Z5Premium from my pocket about 3Feet high then I have same issue just like what described above. i've tried the solution from Shlomi Lisha but it doest work, I thought it was a physical damage.

so i opened the back cover with a heat gun, a glass suction and a clip. then i noticed a socket detached from its place (marked with a red square), i put it back and power on, and finally it work
20181203_100538.jpg

One time poster
Message 66 of 69
306 Views
Message 66 of 69

Re: My power button, volume button, and shutter button sometime doesn't work

Thank you.it helped me so much.

One time poster
Message 67 of 69
181 Views
Message 67 of 69

Re: My power button, volume button, and shutter button sometime doesn't work

It works!!!! I fixed it myself Slightly smiling Face, thanks for your advise!   Maria

One time poster
Message 68 of 69
123 Views
Message 68 of 69

Re: Xperia z5 volume down button

just wanted to thank computercowboy for your link. After trying everything, I risked it and used my microwavable teddy to heat up the phone and scalpels to pry the back off. i didnt need to take anything out as i immediatly found one connection loose. i tested it (powered on the phone) before returning the back and sure enough, it was as simple as that! now im guessing my warranty is void anyway and its not considered water resistant anymore, but its defo cheaper and easier than getting someone to do pretty much the same job with the same outcome.

 

Thanks again!

One time poster
Message 69 of 69
11 Views
Message 69 of 69

Re: My power button, volume button, and shutter button sometime doesn't work

I have met with this problem twice. This time I chanced upon this forum thread and proceeded to removing the back cover of my phone and fixing the detached socket as shown by vanquish_vein. Instantly all dead bottons of my phone came to life.

I live in India. Earlier, when I met with this problem I went to authorized Sony Service Centre. They had charged me Indian Rupees 9500 (around 135 USD value) then, in the name of changing mother board of my phone. A sheer case of robbery.