account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

My power button, volume button, and shutter button sometime doesn't work

SOLVED
Highlighted
Forum Legend
Message 11 of 68
5,433 Views
Message 11 of 68

Re: Power, Volume, Camera buttons, and vibration not working

have you tried to contact your local support? Local support

 

if you can not find a service center near you, you can try to have it repaired by a trusted repair shop. however bear in mind that the warranty will be void, and water resistance is not guaranteed



________________________________________________________________________________
The Man! The Myth! The Forum Legend! -Scott Sterling
One time poster
Message 12 of 68
7,093 Views
Message 12 of 68

Re: My power button, volume button, and shutter button sometime doesn't work

With my phone (Z5) I've got the same problem as others described above. 
It is the trick that Shlomi Lisha told us, gently pressing at the top right corner of the screen, that helped me to get access to my phone again! 
Thanks a lot for this advice! 
 
In the meanwhile I still do own a brand new phone with serious button issues...  
As I'm not the only one, Sony can you please tell us what you will do about this problem?  
 
Dajo
One time poster
Message 13 of 68
5,871 Views
Message 13 of 68

Re: My power button, volume button, and shutter button sometime doesn't work

Hi,
I have the same problem. All the buttons on the right side didn't work, also lost my lower speaker.
This is a hardware issue. There is a FCC connection loose inside. First time I fixed it in sony xperia care store. But after a mild impact, it happens again. I opened back plate, put the FCC back, hot glue it, seal the back plate back.
Problem solved.
I believe this is a design flaw.
One time poster
Message 14 of 68
5,858 Views
Message 14 of 68

Re: My power button, volume button, and shutter button sometime doesn't work

Guys, I've been in nightmare when all the buttons not working after it fell from bed. Luckily the touch screen is doing just fine. So just locked the screen and tap the screen twice to 'wake up' the phone. Since i have to be away from city for quite sometime, i have no time to go to sony centre to check my phone with hope my phone will not shut down till i get back to town. Unfortunately, an unexpected happened with all the effort in making sure the battery keep on running, my battery run out and the power bank also not working. Out of panic, i 'slapped' the back of the phone and guess what, all the buttons working just fine.. Huhuhuhu..
Visitor
Message 15 of 68
5,389 Views
Message 15 of 68

Re: Power, Volume, Camera buttons, and vibration not working

Update, fix.

 

Talked to support and useless as my IMEI says it should have been sold in Panama and not Canada.

Had a friend help me pull the back off.  Super simple, heated up and pulled off with a suction cup. Found 1 plug about and Inch below and 1/2" to the right of the camera was disconnected, one other plug was loose as well.   Resealed with the old adhesive while I wait a week for my 5$ pack of new adhesive to arrive.  We followed the instructions on www.ifixit.com, I'll try and put up a picture of the plug.

 

 

One time poster
Message 16 of 68
5,778 Views
Message 16 of 68

Re: My power button, volume button, and shutter button sometime doesn't work

Do you have by any chance a picture of the location of that FCC connection?

One time poster
Message 17 of 68
5,377 Views
Message 17 of 68

Re: Power, Volume, Camera buttons, and vibration not working

squeeze between your fingers the top right hand side of the screen and back of phone, then press power button or volume, mine started working. but not the snap button, that is still dead. Will have to take it in anyway to get it replaced or fixed. let me know if workedSlightly smiling Face

 

Message 18 of 68
5,745 Views
Message 18 of 68

Re: My power button, volume button, and shutter button sometime doesn't work

I have all the symptoms as well. I've got my screen on double tap to wake up.

 

I'm incredibly disappointed in this situation.

 

I can fix it sure, get it fixed sure. Sony, you do get that this is unacceptable right? Same thing is happening on my mother's Z5.  This is usually a recall type situation. 

 

If I have to send this thing back o want a cross ship on a refirb. 

 

Totally unacceptable 


@eopt wrote:

Do you have by any chance a picture of the location of that FCC connection?


I'll get it

Shameless Sony Fanboy
But I'm starting to lose my faith
Message 19 of 68
5,742 Views
Message 19 of 68

Re: My power button, volume button, and shutter button sometime doesn't work

Also this topic is not solved, I know that Sony does not have this problem on their radar. Which is why I am being so grump. 

 

I don't think I am wrong expecting more. 

I've owned countless Xperia, Erricson and Sony products for my whole life. I still buy VAIO even.

 

You guys at Sony really mucked this up. You had one job! Connections that don't shake lose inside a case that is glued shut.

Shameless Sony Fanboy
But I'm starting to lose my faith
Message 20 of 68
5,731 Views
Message 20 of 68

Re: My power button, volume button, and shutter button sometime doesn't work

I just got off the phone with Sony US and they don't support it, which I knew.

 

I am pushing the angle of defective product, lemon. Going back to Amazon with it

 

Shameless Sony Fanboy
But I'm starting to lose my faith