account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Incoming calls only showing on top bar, no quick answer option

Learner
Message 1 of 11
3,167 Views
Message 1 of 11

Incoming calls only showing on top bar, no quick answer option

Hi all,

 

On my phone when it rings I only have a small notification on the top of the screen, I don't get full screen answer or decline option (or whatever it says, I can't check because I can't see it).

 

I've rang Sony tech support and they said to do a software repair so I've installed Companion etc but that won't work either, I keep getting an error. I was also told it won't wipe my phone but everything I've read online said it will so now I'm dupious about trying it again. 

 

It's on Andrio version 7. Other messages I've seen say to check the settings for InCallUI but I can't find this on my phone at all.

 

Any suggestions?

10 REPLIES 10
Moderator
Message 2 of 11
3,164 Views
Message 2 of 11

Re: Incoming calls only showing on top bar, no quick answer option

@Idemash are you using Z5? Check this:

https://talk.sonymobile.com/t5/Xperia-Z5-Z5-Compact-Z5-Premium/How-to-enable-swipe-to-answer-call/m-...



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

Learner
Message 3 of 11
3,156 Views
Message 3 of 11

Re: Incoming calls only showing on top bar, no quick answer option

Hi,

 

I've read that and it doesn't address the problem. If my screen is locked it remains black when it is ringing. If it is unlocked I can only answer a call from the tiny notifications menu at the top. I never see the answer or decline full screen option that says who is ringing ect. It seems to be a problem with the software for answering incoming calls. It might be a setting or it might be corrupted. I can't find the settings so if someone can direct me to that it would be great. Also clarification on if software repair will factory reset my phone and how to resolve errors when doing that cause currently it just says error 2something and I can't proceed with the repair.

Learner
Message 4 of 11
3,155 Views
Message 4 of 11

Re: Incoming calls only showing on top bar, no quick answer option

I've also read most of the 'Black screen' thread and that is a different issue. It's not the proximity sensor and I have no problem hanging up outgoing calls. Issue is on incoming only. And I've clears the phone app cache and restarted and that didn't work either.

Highlighted
Phy
Forum Legend
Message 5 of 11
3,130 Views
Message 5 of 11

Re: Incoming calls only showing on top bar, no quick answer option

Try booting in safe mode and check it again.

How to boot on safe mode
http://talk.sonymobile.com/t5/FAQ/How-to-boot-your-phone-into-safe-mode/m-p/348008#U348008

How to boot on safe mode on Lollipop

1. press and hold the power key
2. once you get the pop up menu 
3. press and hold "power off" 
4. Boot on safe mode should become available
Learner
Message 6 of 11
3,121 Views
Message 6 of 11

Re: Incoming calls only showing on top bar, no quick answer option

Already tried. No fix. I'm going to uninstall and reinstall the companion thing and thing again. Instructions for how to use that would be helpful because the instructions I was emailed are totally different to what it says on screen.

Sony Xperia Support
Message 7 of 11
3,112 Views
Message 7 of 11

Re: Incoming calls only showing on top bar, no quick answer option

Hi @Idemash,

 

Welcome to the community.

 

Use this link to help you with the software repair: 

http://talk.sonymobile.com/t5/FAQ/How-to-perform-a-software-repair-with-Xperia-Companion/td-p/110305...


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Learner
Message 8 of 11
3,096 Views
Message 8 of 11

Re: Incoming calls only showing on top bar, no quick answer option

I uninstalled and reinstalled companion last night and tried again. It gets half way through initialising then freezes for a minute or so then I get error EUinstallation Wait Time 2.

I noticed it coincided with the message that allows permission for the app to make changes to my computer so I turned off the messages and turned off Windows Defender and tried again. Didn't help. I don't know what makes those "Allow or Deny" messages come up on the PC. I'll try something related to that if anyone has advice.
Sony Xperia Support
Message 9 of 11
3,058 Views
Message 9 of 11

Re: Incoming calls only showing on top bar, no quick answer option

@Idemash,

 

Try running the app as an administrator by right clicking on the icon.

 

If you are still unable to complete the software repair you may have to try another PC.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Message 10 of 11
2,358 Views
Message 10 of 11

Re: Incoming calls only showing on top bar, no quick answer option

I have exactly the same issue on the Xperia xz and xz1. 

 

It's really infuriating. 

I don't hook either of mine up to my laptop. 

What is the solution to getting full screen call info back?

 

Update.... So when the phone rings and I click on the picture it changes to the full screen incoming call, with associated options! But its such a small area to hit.... I just want the fill screen back