account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

How do I disable wifi notifications?

Adviser
Message 1 of 24
5,965 Views
Message 1 of 24

How do I disable wifi notifications?

Hi,

 

I've got Settings|Wi-Fi|Advanced|Network Notification turned off, yet every time I come within the airspace of a WiFi network that I can connect to, I get a browser automatically launching and an audio signal prompting me to connect. Not only is the interruption annoying, also if I'm listening to music then sometimes the interruption halts playback. 

 

On top of that, the audio notification of the Wifi network is broadcast through the phone's speaker rather than through the headphones, which is disruptive for everyone around me.

 

Examples of networks where this happens: the EE network on London Underground, O2 Wifi hotspots, BT hotspots

 

How do I stop this behaviour? I want Wifi network notification to be silent and not interrupt what I'm doing. 

 

Thanks!

 

Tony

 

23 REPLIES 23
Emperor
Message 2 of 24
5,939 Views
Message 2 of 24

Re: How do I disable wifi notifications?

@tony-b

 

you will have to forget those hotspots or check on those specific wifi settings 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Adviser
Message 3 of 24
5,936 Views
Message 3 of 24

Re: How do I disable wifi notifications?

Hi, thanks for the reply.

 

I use the public networks I mention almost daily. I just want to connect to them silently if I've got wifi enabled on my phone. Is that possible?

 

Sorry I'm not sure what you mean by "check on those specific wifi settings". Which settings?

 

Thanks,

 

Tony

Emperor
Message 4 of 24
5,929 Views
Message 4 of 24

Re: How do I disable wifi notifications?

@tony-b

 

Got it, some free public networks require that pop up that you described, @alexdon any suggestions?




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Moderator
Message 5 of 24
5,919 Views
Message 5 of 24

Re: How do I disable wifi notifications?

@tony-b You can't disable those notifications as far as I know, it's nothing from your wifi settings, it's from the network itself. So what you can try is to use vibration mode and see if it still beeps.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

Adviser
Message 6 of 24
5,908 Views
Message 6 of 24

Re: How do I disable wifi notifications?

Thanks for the replies guys.

 

@alexdon does your suggestion about vibration mode mean that every time I passed a hotspot I'd have to alter my ringtones etc to not sound out just because I might get the wifi alert? 

 

Something I've just noticed while rummaging around in my settings - if I click Settings|Sounds & Notifications there's a section called App notifications. Select "Most Recent" at the top and BT Wifi (for example) is near the top. Would this be what's activating the notification when I find myself in BTWifi airspace? Would deselecting "Allow Peeking" make any difference? (it's currently selected). Other settings here are "Block all" and "Treat as priority". (both unselected for BTWifi).

 

Thanks,

 

Tony

 

 

Moderator
Message 7 of 24
5,904 Views
Message 7 of 24

Re: How do I disable wifi notifications?

@tony-b I was about to suggest you to block notifications for an app that has access to see if that makes any difference.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

Highlighted
Demigod
Message 8 of 24
5,883 Views
Message 8 of 24

Re: How do I disable wifi notifications?

Hi tony-b,

 

Can you help to check if you encounter the same under safemode?

 

On safemode you can still connect to wi-fi, let us know if you will still be prompt to connect to a network.

 

If in safemode, nothing prompts. I think there is some app that cause this. If you still encounter the same in safemode.

 

I will suggest you to do a factory reset or software repair.

 

I know there is also some app that could help user to manage their wifi connection which may be the root cause as well.

Adviser
Message 9 of 24
5,883 Views
Message 9 of 24

Re: How do I disable wifi notifications?

When it happened this morning on the tube, I checked my "Most Recent" apps to see who was responsible, turns out it was "Android System".

 

@alexdon any idea what else am I going to lose if I disable "Allow peeking" for this app? 

 

Also, is it only me who's experiencing this? 

 

And why does the notification sound through my speaker rather than my headphones? 

Adviser
Message 10 of 24
5,879 Views
Message 10 of 24

Re: How do I disable wifi notifications?

Thanks for the suggestion @Bandolero. You're going to have to explain how I try it in safemode I'm afraid - thanks Slightly smiling Face

 

(also, how do I tag someone? Just using a plain-text "@" doesn't appear to do it)