account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

How do I disable the proximity sensor on the Z5 premium?

One time poster
Message 1 of 17
7,985 Views
Message 1 of 17

How do I disable the proximity sensor on the Z5 premium?

Hi,

My screen goes black whenever I'm in a phone call.
I have already restored thh phone several times, no avail.  I don't use a case, or a screeen protector.

It's a hardware issue with the phone.  

So anyone kow can I shut off this sensor?  I'm ready to chuck this thing at the wall.

16 REPLIES 16
Message 2 of 17
7,983 Views
Message 2 of 17

Re: How do I disable the proximity sensor on the Z5 premium?

Hi,
That´s a normal behavior. If you are on a phone call, the screen turns off to avoid battery drain out to prevent accidental touches.

But if you put the phone away from your face, the screen will turn on.
_______________
Diogo Simões

This is a user-based global forum. So please, write in english! By doing so, it can be well received and monitored.
If the problem is solved, mark it as a solution so others can know Grinning Face
Sony Xperia Support
Message 3 of 17
7,963 Views
Message 3 of 17

Re: How do I disable the proximity sensor on the Z5 premium?

Hi @DukeOfCrydee, welcome to our forum!

As @diogosimoes4321 wrote, the screen will turn itself off when you are in a call and the proximity sensor is covered by for example, your ear. This is standard behaviour and there is not setting to always have the screen on during a call.

When you take the phone down from your ear and nothing is covering the sensor, the screen will light up again so you can for example, open an application during the call if you need to double check something.

Could you please confirm if the screen lights up when the sensor is not covered, or if the screen is turned off all the time during calls and you can't light it up until the counterpart have ended the call?

If you can't turn the screen on at all during a call and you have already performed a software repair and you don't have a case and screen protector, your phone will need to be examined at an authorized service centre and your Local support will assist you further, so please get in contact with them.

Let us know how it went!


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Message 4 of 17
7,911 Views
Message 4 of 17

Re: How do I disable the proximity sensor on the Z5 premium?

The phone blanks before I put it to my ear & am unable to access screen, is a software control fault, I also reset phone removed screen protector, the only way to acccess screen while on call is to insert handsfree - please SONY fix this

Sony Xperia Support
Message 5 of 17
7,877 Views
Message 5 of 17

Re: How do I disable the proximity sensor on the Z5 premium?

Hi @NicoDreamWork, sorry to hear about this.

If you have already performed a software repair using Xperia Companion and you still experience that the screen turns off when you tap on the call button or that the screen does not light up when you take it away from your ear, it does sound like it is related to hardware and not software.

However, if you restored a backup after you reset the device, or if you installed new applications. Try rebooting your phone in safe mode. This will temporarily disable downloaded applications so we can see if any of them is the cause of this.

While the phone is rebooted in safe mode, go to Settings > About phone > Diagnostics > Test > Ear proximity. Does the phone vibration even when your hand/finger is not covering the proximity sensor?

If it does, your phone will need to be examined at an authorized service centre and your Local support team will assist you further and answer any questions you may have regarding local service routines, warranty and so forth.

Let me know if that helps!


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Learner
Message 6 of 17
6,469 Views
Message 6 of 17

Re: How do I disable the proximity sensor on the Z5 premium?

I have the same problem

 

Message 7 of 17
6,411 Views
Message 7 of 17

Re: How do I disable the proximity sensor on the Z5 premium?

Hi @Assim1

 

Did you follow @Jonas tips?

_______________
Diogo Simões

This is a user-based global forum. So please, write in english! By doing so, it can be well received and monitored.
If the problem is solved, mark it as a solution so others can know Grinning Face
Sony Xperia Support
Message 8 of 17
6,401 Views
Message 8 of 17

Re: How do I disable the proximity sensor on the Z5 premium?

Hi @Assim1, sorry to hear about this.

Have you tried any of the troubleshooting steps that I have previously suggested in this thread? If you haven't done that, I would recommend that you start with making sure that the proximity sensor is not covered by a screen protector and make sure that there is no dust or moisture.

Let me know how it went! Slightly smiling Face


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Highlighted
Enthusiast
Message 9 of 17
6,387 Views
Message 9 of 17

Re: How do I disable the proximity sensor on the Z5 premium?

This is happening to me too. I think it all started when the screen was replaced. What I learned is that when the screen goes black, I cover the proximity sensor or touch it with my finger and usually, the screen goes live again. After doing it once, I can take the phone to my ear and then back off and the sensor works normally. 

Sony Xperia Support
Message 10 of 17
6,359 Views
Message 10 of 17

Re: How do I disable the proximity sensor on the Z5 premium?

Hi @CharlesJ, sorry to hear about this. Slightly frowning Face

That sounds very strange and that is not how the sensor is supposed to work. It should only go dark when it's covered by for example, your ear and you should not have to cover it again to make it light up again. Was the display replaced at an authorized service centre?

You can also make sure that there is no dust or moisture at the sensor by cleaning the top part of your display with a dry cloth.

Let me know if that helps! Slightly smiling Face


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.