account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Headphone jack not working

SOLVED
Visitor
Message 91 of 574
3,471 Views
Message 91 of 574

Re: Headphone jack not working

I'm pretty sure is a physical problem, not a software problem. During the days I had the problem I was out of home and didn't update anything. Hope Sony change the audio connector provider because is really bad quality.

 

Also I found a solution,

I sold my phone on the chinese black market. I bought a new iPhone 6S.

 

Solved.

One time poster
Message 92 of 574
3,449 Views
Message 92 of 574

Re: Headphone jack not working

This just happening to me,, did Sony Warranty can cover this problems?
Adept
Message 93 of 574
3,427 Views
Message 93 of 574

Headphones connected while it isn't error

After being submerged in a glass of water i got an message saying headphones are connected and then disconnected 0_0 while my phone pass successful the pressure test , is this normal due that the headphones isn't covered? But why i don't have this issue with my z1?
One time poster
Message 94 of 574
3,368 Views
Message 94 of 574

Re: Headphone jack not working


@marlboro5109 wrote:

Hi All,

 

same problem with my Xperia Z5, headsets not reconized just right after 6.0 update....

 

Smart Connect uninstalled but same behaviour

 

The headset himself works (with soundabout), it's only the detection event that's won't works :

 

 - hardware issue ? a pin used for detection only that should be damaged ? exactly at the same time I updated to 6.0 ? can't beliveve it. I tried to clean up the jack with no effect.

 - software ? possible. but it's not smart connect, the automatic detection does not work even with soundabout. I think it should be a system issue ... I run 6.0.1, is there an update planned to fix this isssue ?

 

Thanks,

Olivier

 


 I had also an issue with my Xperia Z5 Dual. Headphones wasn't recognised by mobile after update 13 July 2016. 

 

But I managed to solve to problem and I would like to tell how I did it.

Simply, I did Software Repair with Xperia Companion. After a success repair and phone restore from Google, my headphones works as expected in any application (e.g. Radio, AIMP, Google Music etc.) without additional software.

 

So I would like to recommend you to do a Software Repair with Xperia Companion to resolve issue with headphones.Be careful and patient and follow the instructions

 

BTW, make sure that your headphones are working with other device.

 

Thanks

One time poster
Message 95 of 574
3,323 Views
Message 95 of 574

Re: Headphone jack not working

I just had that problem a few minutes ago. I restarted my phone with my earphones plugged in. The issue is fixed. I have Z5 compact. Electronics sometimes need to be restarted to refresh their temporary memory when they get slow or something. I am not an expert but restarting devices worth trying most of the time.
One time poster
Message 96 of 574
3,307 Views
Message 96 of 574

Re: Headphone jack not working

I have the same problem in my Z5 Premium, it had never been such a problem! I realized that occurred after upgrading to Android MM version (6.0). Clean SmartConnect application allowed me to recognize the headset, but soon after it stopped working ... Using Soundabout application the headset normally works for listening to music. It is quite clear that this is a bug in the firmware, not hardware.
One time poster
Message 97 of 574
3,274 Views
Message 97 of 574

Re: Headphone jack not working

I have tried the app but still not working

Apprentice
Message 98 of 574
3,198 Views
Message 98 of 574

Re: Headphone jack not working

Hi All,

 

@Bonita : I tried to restart the phone with the headset plugged in, but without any effect...

 

@Sturman : I just installed Xperia Companion and it show me an available update (32.2.A.0.253). I'am actually running the 224.

So I will try this update prior to make a repair ... 

I will put some information here ...

 

 

Olivier

Apprentice
Message 99 of 574
3,186 Views
Message 99 of 574

Re: Headphone jack not working

ok, I installed the 253 update (2.5Gb) but always the same problem...

 

I will try a repair later ... 

 

Olivier

Apprentice
Message 100 of 574
3,242 Views
Message 100 of 574

Re: Headphone jack not working

Other news : after a reboot (with headset plugged in) the headset is working if I plug it / unpluged it / plug it again quickly ...

It's not the way I want to use such a phone but It's better than nothing ...

 

Olivier