account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Do not disturb mode previous feature missing

Highlighted
Adviser
Message 11 of 51
870 Views
Message 11 of 51

Re: Do not disturb mode previous feature missing

Rickard, I see this options. But when I set them correctly it doesn't work.

 

What do I do?

 

1) I make a 'star' of the contact of my girlfriend

2) I go too -> allowed as priority -> calls -> only contacts with a star

3) I set do not disturb on 'only priority'

 

My girlfriend calls and I here no sound. What am I doing wrong?

Sony Xperia Support
Message 12 of 51
858 Views
Message 12 of 51

Re: Do not disturb mode previous feature missing

I'm not sure, it works fine for me.

Could it be the ring volume that is turned down? While in this mode, you can still adjust ring volume using volume keys.

This is what i did:

First star the contact, then go to Settings -> Sound & notification -> Do not disturb -> Priority only allows -> Calls -> From starred contacts only. Then swipe down notifications bar to access quick settings, tap "Do not disturb" and then tap "Priority only". When the starred contact calls me i hear the ringtone.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Commissioner
Message 13 of 51
854 Views
Message 13 of 51

Re: Do not disturb mode previous feature missing

@Rickard

 

It doesn't work for me too. I have 6 contacts starred and when I set "do not disturb" mode and allow in settings calls from "starred" contacts and then I call from that (starred) number phone doesn't ring at all. Tried for options (don't exactly name inenglish, I'm using Slovak mutation): completely silent and alarms only. None of them work.

 

Only "priority only" works with starred sontacts. BUT...

 

...then I don't understand WHY is there option to go to the settings when you select completely silent and alarms only modes and this settings don't fit for this modes. Settings are applied only for priority only mode.

 

What about to remove these settings menus from those 2 modes???

 


:loop; start "" %0; goto loop
Regular
Message 14 of 51
799 Views
Message 14 of 51

Re: Do not disturb mode previous feature missing

Not sure how you try to switch do not disturb on, but they key is how (from where) to switch it on.

 

If you switch it on from the physical sound button, only option available is "Alarms only".

This is how it worked in Lollipop (5.1.1), but not anymore in Marshmellow (6.0.1).

 

With Marshmellow you need to swipe down notifications bar to access quick settings* and select "Do not disturb".

After that you should have possibility to choose from "Total silence", "Alarm only" and "Priority Only" + some other setting.

 

*As first time effort you may need to add "Do not disturb" icon to Quick settings.

 

I have z3, but I'm pretty sure this applies to other xperias as well.

 

Sage
Message 15 of 51
786 Views
Message 15 of 51

Re: Do not disturb mode previous feature missing

You can also program the type of contacts enabled to call you in the panel settings-audio-do not disturb-priority-calls.

Commissioner
Message 16 of 51
782 Views
Message 16 of 51

Re: Do not disturb mode previous feature missing

i have set in "priority only" few starred contacts, but during this mode also facebook, messenger notifications are on and played even i have no set for them...


:loop; start "" %0; goto loop
Visitor
Message 17 of 51
771 Views
Message 17 of 51

Re: Do not disturb mode previous feature missing

I too am having issues with Do Not Disturb.  It seemed to be working fine until last week - has something changed in an update?  I never managed to get the 'priority only' to work (I thought I'd set it up right, until my boyfriend tried to ring in an emergency and guess what - it didn't work.  Thanks Sony...)  but at least it was silent when I wanted it to be silent.  Now, however, it 'appears' to be in Do Not Disturb mode (the icon appears) but I got through email, whatsapp and text messages last night, which woke me up each time.  

 

I'm also getting conflicts with my third party alarm 'Gentle Alarm', which I've used for many years on different Android devices, but occasionally the set alarm sound will be bypassed by the harsh default bleep.  I think this has something to do with Do Not Disturb also.

Learner
Message 18 of 51
716 Views
Message 18 of 51

Re: Do not disturb mode previous feature missing

It's now mid May and this feature is still missing! I used to use it daily before the update removed it - any plans to fix?

Inhabitant
Message 19 of 51
689 Views
Message 19 of 51

Re: Do not disturb mode previous feature missing

Can you also reply to the topic!?

 

Can you confirm "until next alarm" comes back in a next update?

I use this feature EVERY DAY! And suddenly it's gone Slightly frowning Face

 

BTW I have 6.0.1 and don't have the feature. I don't know if my phone updated and skipped 6.0.0 but just a few days ago I still had the feature and now it's gone!

Apprentice
Message 20 of 51
670 Views
Message 20 of 51

Re: Do not disturb mode previous feature missing

Same here. I have Marshmallow 6.0.1. It's been two or three days now that the "do not disturb until next alarm" feature is missing.