account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Bluetooth audio won't connect after update to Android 7.0

Highlighted
One time poster
Message 51 of 149
1,687 Views
Message 51 of 149

Re: Bluetooth handsfree audio disconnect when call connects

I have the same problems at my Z5 premium, software version Nougat 378. Hope Sony Will solve this issue soon.
One time poster
Message 52 of 149
1,681 Views
Message 52 of 149

Re: Android 7 messed up Bluetooth volume control (Xperia Z5)


@redi1972 wrote:
With the Android 7 update of my Xperia Z5, the volume control of Bluetooth devices had become very unbalanced. The step from level 3 to 4 is much too large, it goes from a slightly too low volume to way too loud. Is this Android itself, or the Sony implementation? It was fine in Android 6.

I second this, a clear skip has appeared between volume levels 3 and 4. I can actually hear the volume to go up or down two levels at a time when i push the volume control buttons or adjust the volume slider on screen. I have a Z5C.

(When this is paired with the ridiculous logarithmical volume control on JBL Charge 2+ the issue is really annoying. The volume is basically either too low or too high all the time when used indoors.)

Regular
Message 53 of 149
1,660 Views
Message 53 of 149

Re: Bluetooth handsfree audio disconnect when call connects

Bluetooth audio got corrupted here as well, connection with my car (Mazda 6) works but audio playback randomly pauses and requires me to start it again each time, and it sometimes also switches to a different audio player (not Sony's Music but the 7Digital player).

Learner
Message 54 of 149
1,692 Views
Message 54 of 149

Re: Bluetooth issue after update Nougat Android 7.0

Hi,

 

I'm using a z5 compact (E5803) and obviously having the same trouble you are experiencing... but i have a workaround: everytime i'm gonna connect a accesory (headset, car audio) I connect it as always, everything that is bad will be still bad, but... if i restart my phone with the accessory connected and Bluetooh still ON, before the rom loads completely the accessory reconnects again a voila! all the troubles will be gone!... pitifully, if I disconnect it again the troubles will be back.

 

I tried with my BT headset (MDR100ABN), and my car audio (PIONEER) and confirm with both ones this workaround success, so... maybe you wanna give a try until SONY brings a proper fix to this.

One time poster
Message 55 of 149
1,647 Views
Message 55 of 149

Recent sony update stripped bluetooth functionality

Hi. Following the recent Sony update my z5 compact now doesn't allow other devices to control the handset functions via Bluetooth except volume. I have removed all Bluetooth devices and paired again to no avail. Basically now my handset cannot be used for music or other useful functions anymore via Bluetooth. It is a z5 compact running Android 7.0
Rookie
Message 56 of 149
1,604 Views
Message 56 of 149

Re: Bluetooth audio won't connect after update to Android 7.0

Hello,

I have receive a feedback from Sony Support. They say this issue is not old and happens always after big updates. Due to the version updates on the smartphone from 6 to 7, but not on the software from the car system which is still the old android it is needed to update also the car android version. So you need to contact your car seller and ask for an update or when it is planned!

After this everything should work fine again.

I will contact on my volvo dealer on monday to check for the update.

For me it is clear. Next time I will wait first for the car update before to upgrad the smartphone!!

 

One time poster
Message 57 of 149
1,696 Views
Message 57 of 149

bluetooth media audio not working

I cant connect my phone to the car as media audio only as call audio
Moderator
Message 58 of 149
1,695 Views
Message 58 of 149

Re: bluetooth media audio not working

@badr3

 

What phone do you have? Cuz I'm pretty sure it's not an XZ premium!

Also what Android version are you on?



Feel free to kudo this post or mark it as solution so that other users facing the same issue can find it

Disclaimer: Moderators are not affiliated with or work for Sony Mobile, their posts represent their own opinions and views. Click here to find out more about the different roles in the community.

Learner
Message 59 of 149
1,652 Views
Message 59 of 149

Re: Bluetooth issue after update Nougat Android 7.0

@Quester

 

Hi, perhaps my headset was new, I tried resetting it and still only works with the workaround, also my car audio still get the issue, and only works with the workaround.

Regular
Message 60 of 149
1,516 Views
Message 60 of 149

Re: Bluetooth audio won't connect after update to Android 7.0

Do all cars run on Android? I never knew that (and I actually doubt it...).

 

The point is, however, that BlueTooth functionality has been completely buggered with Android 7.0. I am listening on a BlueTooth headphone set right now and had something very odd happened just seconds ago: I already reported in another thread that the BlueTooth volume control has been messed up, the step between levels 3 and 4 is way too big. Just now, however, while playing at volume level 3 I tried to adjust the volume on my headphones, and it showed on my phone that the BlueTooth volume was at a completely different level. The volume level was suddenly much better, though, and with better spacing between the levels! However, it wouldn't go below ~50% when adjusting on my headphones, there would be some sort of error signal from my headphones. I then adjusted the volume directly on my phone and it jumped back to the normal bad volume settings, and now it stays like that also when adjusting it on my headphones. So somehow the communication between phone and headphones went haywire at first, which it never did before on Android 6.0.