account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

my Z3 radio Fm no sound

SOLVED
One time poster
Message 11 of 32
2,254 Views
Message 11 of 32

Re: my Z3 radio Fm no sound

same problem also for me

 

One time poster
Message 12 of 32
2,243 Views
Message 12 of 32

Re: my Z3 radio Fm no sound

Same here.

It shows what station I'm supposed to be listening to, and shows whether audi should be routed through the earphones or speaker.

Funnily enough though, nothing comes out of either of them!!!

 

Kieron

One time poster
Message 13 of 32
2,200 Views
Message 13 of 32

Re: my Z3 radio Fm no sound

It's not working even after starting phone in safe mode.
Please help me with this.
One time poster
Message 14 of 32
2,134 Views
Message 14 of 32

Re: my Z3 radio Fm no sound

I have just updated to lollipop 5.1.1 and still the Radio issue assosiated with the Ok Google voice search
One time poster
Message 15 of 32
2,079 Views
Message 15 of 32

Re: my Z3 radio Fm no sound

I found a workaround. The radio works fine.....but only when the phone is locked. You need to use the radio app to tune to the station you want. Then hit the lock button and the radio works (only if headphones plugged in).

This is very annoying if you want to use the radio and see the screen, for example to use another app.
Highlighted
Visitor
Message 16 of 32
1,845 Views
Message 16 of 32

Re: my Z3 radio Fm no sound

I have a workaround. It's annoying but works.
In the fm app open (in the upper-right corner). The sound will start playing. After this you let the screen go to sleep. Do not close the screen yourself since it will stop trackid. After it went to sleep you can use your phone as normal and the sound will keep playing.

Note: I did try the Clear data/Restart trick first, so maybe this is necessary too. (settings-apps-all-fm radio -> Clear data. After this restart)
Visitor
Message 17 of 32
1,844 Views
Message 17 of 32

Re: my Z3 radio Fm no sound

In my previous post it should say "in the fm app open Trackid"
One time poster
Message 18 of 32
1,807 Views
Message 18 of 32

Re: my Z3 radio Fm no sound

Thanks, had this problem for months and finally this works, now I can actually use my phone and listen to the radio at once! 😂 📻 

One time poster
Message 19 of 32
1,680 Views
Message 19 of 32

Re: my Z3 radio Fm no sound

No one has really answered the question with a proper fix. The problem is caused by Google Now. Go to google settings app>search&now>voice>ok google detection>turn off. Sound will then work. You don't need to clear any radio cache etc.
You can also get to google settings in pretty much any google app. Just disable voice search option.
You can double check by turning it on again while the radio is running and it will mute the sound again.
Regular
Message 20 of 32
1,634 Views
Message 20 of 32

Re: my Z3 radio Fm no sound


@bscared wrote:
No one has really answered the question with a proper fix. The problem is caused by Google Now. Go to google settings app>search&now>voice>ok google detection>turn off. Sound will then work. You don't need to clear any radio cache etc.
You can also get to google settings in pretty much any google app. Just disable voice search option.
You can double check by turning it on again while the radio is running and it will mute the sound again.

Excellent:

thanks, thanks and thanks again

set to off OK google and radio voice comes up again

surprising Sony team did not solve and no contribution