account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Z3 LTE

One time poster
Message 1 of 2
310 Views
Message 1 of 2

Z3 LTE

LTE is not working

1 REPLY 1
Highlighted
Sony Xperia Support
Message 2 of 2
307 Views
Message 2 of 2

Re: Z3 LTE

Hi @Donadoni, sorry to hear about this. Slightly frowning Face

Have you ever had an LTE connection with your Xperia Z3, or is this something that just started to occur?

To start with, download the Internet settings in your device and you can do that under Settings > More > Internet settings, tap "Accept" and wait for the download and installation to complete > restart your device.

You can also make sure that you are in an area with LTE coverage and that your SIM card/subscription is capable of LTE.

Let me know if that helps!


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.