account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Xperia Z3+ (single sim) does not Fast Charging

Apprentice
Message 1 of 11
2,455 Views
Message 1 of 11

Xperia Z3+ (single sim) does not Fast Charging

Issue with Fast Charging 2.0. I just bought the fast charing charger and it works only with my tablet Z2 on 6.0 and not on my phone Z3+.

Actually I have an Xperia Tablet Z2 and a Z3+ (single sim). I just bought the fast charger for my devices since they are both accepted for Fast Charging 2.0. Now my tablet Z2 is on android 6.0 and my phone Z3+ on 7.0 and the last one does not fast charge with the exact same charger and cable used! So I believe is due to Nougat issues if I am not mistaken. I tried in Safe mode, nothing changed, they asked me to repair my phone software, that I will done in the coming days, but I am sure it will not resolve the problem, then need to send it back in warranty for something I do believe is a software problem??!!

Dear Sony team, have you checked the probability that you forgot to include it in the software update with Nougat 7.0?

Have someone had the same issues with a Z3+ or Z5 since the update to Nougat, or is it working fine for you?

Thank you for the support.

10 REPLIES 10
Talent
Message 2 of 11
2,027 Views
Message 2 of 11

Re: Xperia Z3+ (single sim) does not Fast Charging

i got fast charger with my Z3+ E6553, Charger model is UHC-10.. and it quickly charge my device.. no problem with it.. I'm in latest version of Android.. 

Highlighted
Commissioner
Message 3 of 11
2,019 Views
Message 3 of 11

Re: Xperia Z3+ (single sim) does not Fast Charging

@Sangeeth47 _ can i know ur device android version  7.1 or.7.0?  fast charging issues r Still present in 7.0 which has been a major issue under hotter environments! 

 

Talent
Message 4 of 11
2,004 Views
Message 4 of 11

Re: Xperia Z3+ (single sim) does not Fast Charging

7.0 bro...  i think you have problem may be because of hotter enviornment... try to charge device while cool enviornment or (night) if still problem occur, try to ampere app to measure the charging current and measure temperature while charging... 

Commissioner
Message 5 of 11
1,997 Views
Message 5 of 11

Re: Xperia Z3+ (single sim) does not Fast Charging

@Sangeeth47 _Thanks for letting me know!! It's coz of the heat generated in the device even wen it's off !! I thought u was on 7.1 wen u said that u don't hav this issue since some heating issues got resolved with that build. Off the topic!!  Did u got the update?  OTA or Xperia companion Upside-down Face

Apprentice
Message 6 of 11
1,983 Views
Message 6 of 11

Re: Xperia Z3+ (single sim) does not Fast Charging

Thank you for the comments and helping me out.

I tmade me understand that I am not alone to have the problem, I also tought it was a software problem since the update to 7.0, but now that it seems to be from the device, I will send it back to warranty, feel pity it happened, since I really like the Sony phones and never had any issues with my Z1 or Z2 tablet.

PS: With the amp app, I never pass above 1300amp, even with the fast charger, I really wonder why, but I prefer they found the cause, hope the warranty service goes fast, I will need my phone asap, that's always the issue.

Talent
Message 7 of 11
1,974 Views
Message 7 of 11

Re: Xperia Z3+ (single sim) does not Fast Charging

My device is at Service Center since 2 months before... very bad at Service Center.. (when i get my device to check few days before.. i didn't get OTA of 7.1. now i can't check my device, it's again submitted to Service Center.)

Apprentice
Message 8 of 11
1,963 Views
Message 8 of 11

Re: Xperia Z3+ (single sim) does not Fast Charging

That's exactly why I am afraid to send it to service center, cannot work without my phone, always anoying for something not your fault :S

Apprentice
Message 9 of 11
1,763 Views
Message 9 of 11

Re: Xperia Z3+ (single sim) does not Fast Charging

So I come back to you after few months of repairing and come back.... And guess what!?

The phone remain with the same issue and apparently I can ask for an exchange phone but they said that my phone is without problem even after I showed them the proofs!

Who have I to shake in this forum to ahve a real support for my problematic device! Few months without my phone, selling fake advertisment of fast charging and nothing to do!

Is someone competent in this forum or sony support competent to treat my problem?!

Commissioner
Message 10 of 11
1,699 Views
Message 10 of 11

Re: Xperia Z3+ (single sim) does not Fast Charging

@AKflight fast charging is reportedly broken for some users with latest build 7.1  (.1.54)!! U can downgrade to last working build if u need!!