account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

WiFi - Exclamation Mark!

SOLVED
Highlighted
Learner
Message 1 of 38
91,605 Views
Message 1 of 38

WiFi - Exclamation Mark!

 

Hey guys this phone is amazing and is working fine, however ever since I got it my WiFi has had an exclamation mark next to it all the time, whether I'm hooked onto my home network, or my work network. The wireless works perfectly fine, extremely fast etc. However it's just a little annoyance as the exclamation mark is always there, even when mobile data is disabled?

 

Any help?

 

SONY.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
Master
Message 2 of 38
141,978 Views
Message 2 of 38

Re: WiFi - Exclamation Mark!

Well that's a new one for me. Haven't seen it before actually. Found this solution on another site, could be worth a shot:

Go to settings > WiFi > press and hold the connection you have issue with > modify network > tick advanced options > IP Settings drop down > select Static > enter the IP address you want, gateway (your routers IP address), DNS1 and DNS2 (find them in google). Network prefix length was set to 24 on mine and I left it like that, I can now connect to my home WiFi with no problem.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

View solution in original post

37 REPLIES 37
Master
Message 2 of 38
141,979 Views
Message 2 of 38

Re: WiFi - Exclamation Mark!

Well that's a new one for me. Haven't seen it before actually. Found this solution on another site, could be worth a shot:

Go to settings > WiFi > press and hold the connection you have issue with > modify network > tick advanced options > IP Settings drop down > select Static > enter the IP address you want, gateway (your routers IP address), DNS1 and DNS2 (find them in google). Network prefix length was set to 24 on mine and I left it like that, I can now connect to my home WiFi with no problem.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

View solution in original post

Genius
Message 3 of 38
91,535 Views
Message 3 of 38

Re: WiFi - Exclamation Mark!

This to me looks more like an arrow pointing down the way......as if informing you of a download in progress Thinking Face

Learner
Message 4 of 38
91,500 Views
Message 4 of 38

Re: WiFi - Exclamation Mark!

You legend! Resolved it perfectly! Slightly smiling Face

Master
Message 5 of 38
91,497 Views
Message 5 of 38

Re: WiFi - Exclamation Mark!

Great! 

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

One time poster
Message 6 of 38
91,320 Views
Message 6 of 38

Re: WiFi - Exclamation Mark!

This is the reply I get from Sony Singapore

 

Quote

 

With regards to the issue, you are experiencing. Please be advise that this is a bug on Android lollipop 5.0 above. Google made this technically to indicate if the device will have access to google server. Some country may have this on the W-Fi icon as their restricted to have access to google server.

 

Some user may also experience this while connected to an un-secure Wi-Fi network such as public Wi-Fi this is due to the DNS. The device is connected to the host proxy of the public W-Fi and not directly to the ISP.

 

At the current point, We do not have any information about the following issue, however on Android 5.1 update may resolve this.

 

Unquote

Apprentice
Message 7 of 38
91,074 Views
Message 7 of 38

Re: WiFi - Exclamation Mark!

yep i can confirm what Samuel said.  Earlier this year I changed my wifi hardware and now even on my laptop I have to manually setup the ip and dns etc.

Enthusiast
Message 8 of 38
89,860 Views
Message 8 of 38

Re: WiFi - Exclamation Mark!

I have tried the mentioned solution but it does not work for me and I have also tried on both 2.4GHZ and 5.0GHZ, both also have the "!" on the WIFI Signal Icon after you disconnect from the router and connect back again.

 

This is very irritating and I also worry that it is using the Mobile Data instead of the WIFI data.

Adept
Message 9 of 38
89,403 Views
Message 9 of 38

Re: WiFi - Exclamation Mark!

My mistake. Again Exclamation ❗ mark came in all WiFi connections.
One time poster
Message 10 of 38
88,066 Views
Message 10 of 38

Sem conectar o Wifi no Z3 - No Connect the Wifi not Z3

Translated by Google Translate

 

Me I can not connect a local My wi -fi, agora appears How About I'm Connected with More An exclamation Next to the symbol to Wifi Making How can not access anything.