account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Couldn't pair with xxxx Because of an incorrect PIN or Passkey

Sony Xperia Support
Message 11 of 35
31,436 Views
Message 11 of 35

Re: Couldn't pair with xxxx Because of an incorrect PIN or Passkey

@alainnorgate

Sorry to hear that your bluetooth is still not working properly.

As this still happens after a software repair, i recommend that you contact a service centre to have your phone checked and this fixed. For information on how to submit your phone for repairs and where, please contact your Local support.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Rookie
Message 12 of 35
31,224 Views
Message 12 of 35

Re: Couldn't pair with xxxx Because of an incorrect PIN or Passkey

I have same problem with my z3 compact! And nothing not helping!
Rookie
Message 13 of 35
31,220 Views
Message 13 of 35

Re: Couldn't pair with xxxx Because of an incorrect PIN or Passkey

And this happens when I listened music for my LG device. It's working correctly like a month and today one moment the connection is ending in the middle of listening music.
Rookie
Message 14 of 35
31,214 Views
Message 14 of 35

Re: Couldn't pair with xxxx Because of an incorrect PIN or Passkey

And I find solutions for my problem. I disconnected my LG device for power connection for a while. And now everything working correctly!
One time poster
Message 15 of 35
30,809 Views
Message 15 of 35

Re: Couldn't pair with xxxx Because of an incorrect PIN or Passkey

Did you finally find the solution to this? please help Slightly frowning Face

Same problem as original post

pvk
One time poster
Message 16 of 35
30,508 Views
Message 16 of 35

Re: Couldn't pair with xxxx Because of an incorrect PIN or Passkey

What you can do about pairing failures. Make sure Bluetooth is turned on. Determine which pairing process your device employs. Turn on discoverable mode. Make sure the two devices are in close enough proximity to one another. Power the devices off and back on. Power down likely interferers.
One time poster
Message 17 of 35
30,003 Views
Message 17 of 35

Re: Couldn't pair with xxxx Because of an incorrect PIN or Passkey

Do have the same with my Z3,god a New Phone onde, still have the same problem. Was told to put the divice that i should connect to the code 0000. The problem is it not go on the divice in the truck. Then they told that Sony did not work with all Bluetooth in cars, strange as it works with all the other Phone i've tried. Then there will be another brand next time i buy a phone. :-(
One time poster
Message 18 of 35
29,761 Views
Message 18 of 35

Re: Couldn't pair with xxxx Because of an incorrect PIN or Passkey

Hi there! I had the same problem with my Xperia S (Android 4.1.2). I had to reset it to default settings due to some issues. After that Bluetooth connection stopped working and I couldn't pair the phone with my headphones. Nothing helped, erasing Bluetooth data and cache, running the safe mode etc.

Then I tried connecting by NFC and boom it worked! Afterwards I could pair it easily by using just Bluetooth. I hope it helps ;p

One time poster
Message 19 of 35
28,211 Views
Message 19 of 35

Re: Couldn't pair with xxxx Because of an incorrect PIN or Passkey

I tried deleting data from smartconnect and rebooting in smart mode.  It still complains that it's an incorrect PIN.  Do people try these solutions before posting them, or just guess at what might work. I just wasted a half hour of my life that I'll never get back. Thanks.

 

Highlighted
One time poster
Message 20 of 35
27,673 Views
Message 20 of 35

Re: Couldn't pair with xxxx Because of an incorrect PIN or Passkey

I tried this solution and it didn't work for me.