account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Can't connect to PC using genuine Sony USB lead.

Highlighted
One time poster
Message 1 of 1
877 Views
Message 1 of 1

Can't connect to PC using genuine Sony USB lead.

Bit of an odd one this.

 

I've managed before (within the last 3 weeks) to connect to my PC using usb cable correctly. It charged the phone etc. Now it won't connect unless I set the USB mode to MIDI.

 

I've tried re-installing the software (Android 6.0.1 Build .2.A.0.305) as that has cured this problem in the past but not this time. The phone charges correctly when using a mains charger or mains USB charger. It also charges correctly from my van using USB fine. It will charge correctly from the PC when the phone is switched off as well.

 

So when I plug the USB lead into the phone ( already plugged into PC and yes, Ive tried several different ports and even tried it on the laptop ) the phone "beeps" to say that its detected the USB connection - brings up the menu for USB options (Charging, MTP & MIDI) - but will not charge unless I select MIDI - the PC detects the phone then. It will not detect it in either of the other two settings.

 

As I've said, I've tried the original sony lead and several others,  but nothing seems to wor. The phone is not rooted or anything else.

 

Help Please.

 

TIA

Dave