account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Barometer Connection with Waterproofing to Clarify Service Center

Highlighted
Talent
Message 1 of 1
1,548 Views
Message 1 of 1

Barometer Connection with Waterproofing to Clarify Service Center

I have Xperia Z3+ E6553, I bought this phone at 22/Jun/2016. at last month i had a problem with touch, i go to service center (Madonna Parakkandy Service center , Kannur, Kerala, India) on 2/Jun/2017  and they took my device, they said there is no service in here, so we need sent your device to cochin (about 400km far away from here). when i submit my device to there i'm told them, i need my waterproofing like when i bought that device, they said it will be checked from cochin. after waiting about 19 days i got my device back, but the problem starts here, now there is no waterproofing in my device (i'm checking waterproof by applying pressure by thumb, barometer only changing value after decimal point, now it's not increasing the value before the decimal point)  & camera position littlebit moved to right side. and next day i'm submit the device again to service center (22/Jun/2017), after that i got the device again yesterday (04/Jun/2017), they said camera position is fixed, there is no problem with the waterproof & barometer values. I told them that "I'm 100% sure that there is no waterproof in my device, because when i apply pressure (in service test menu) there is no changes in values before the decimal point, when i say this to service staff, they are saying service test is not accurate & in all device the value only change like this". is there anybody to help me? or how i can prove that my device is not waterproof..