account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Z3 tablet LTE vibration dont work

Rookie
Message 1 of 7
2,054 Views
Message 1 of 7

Z3 tablet LTE vibration dont work

Hey, I just got my Z3 tablet LTE and the vibration dont work at all.

I have run the vibration test under diagnostics and it failed. I've have tried to reset to factory settings but it didn't help.

 

Any tips? or should I clame D.O.A? 

6 REPLIES 6
Emperor
Message 2 of 7
2,053 Views
Message 2 of 7

Re: Z3 tablet LTE vibration dont work

Repair your phone with PCC and check again

 

PC Companion (PCC)

 

 

Bridge (for Mac)

 

 

 

Alternatives on How to backup Xperias

 

http://talk.sonymobile.com/thread/36355

 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Emperor
Message 3 of 7
2,051 Views
Message 3 of 7

Re: Z3 tablet LTE vibration dont work

If PCC doesn't work, then contact your local Xperia Care

 

http://support.sonymobile.com/global-en/contactUs/

 

as it could be a hardware issue. 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Sony Xperia Support
Message 4 of 7
2,016 Views
Message 4 of 7

Re: Z3 tablet LTE vibration dont work

Hi nectman,

 

Welcome to the community! Since you're new please be sure that you have checked out our Discussion guidelines.

 

I suggest you take the device back to the place of purchase, especially if the vibrator is not working since the day of purchase.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Rookie
Message 5 of 7
1,957 Views
Message 5 of 7

Re: Z3 tablet LTE vibration dont work

Actully it did work for 5min or so. I went back to the reseller and I got a new one . And the new tablet z3 has exactly the same problem... At first The vibration works. I turnd The vibration on for The keyboard and whenever I touch the screen. After a couple of minutes the vibration failed agen. And I can't get it working... What is the chance that two different has the same fault?  it must be a software problem??

 

This is my first and last Sony tablet.....

One time poster
Message 6 of 7
1,745 Views
Message 6 of 7

Re: Z3 tablet LTE vibration dont work

I have a similar problem.

The vibration motor stops working if I type extensively. It starts working after the device has sat around for a while.

It seems like it needs a "cool down period" or something.

I suspect a hardware issue.

Also the vibration motor is very harsh on my device. There is no way to scale it back.

I'm gonna take the device back and exchange it I think...

Rookie
Message 7 of 7
1,717 Views
Message 7 of 7

Re: Z3 tablet LTE vibration dont work

After a few days testing I found out that my new Z3 tablet has the same problem as yours. When I type extensively the vibrations stop working, but when I turn/tilt the Z3 from "portrait" to "landspace" its working agen. But after a wile its stop working and I have to turn the tablet back to portrait to get it working.

 

I´ve found out that more people in Sweden has the same problem...

 

I dont know if it just switching from portrait and landscape and vice versa that fix the problem (software), or if it´s like you said, it just need to rest to work agen.