account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Z3 Tablet stuck in bootloop

One time poster
Message 1 of 5
Message 1 of 5

Z3 Tablet stuck in bootloop


I have a Z3 tablet compact Wi-Fi, stock, no root, that is in a boot loop at the black and white Sony logo. Repair using Xperia companion is successful, but the loop continues. I've also tried flashing stock ROM using Flash Tool. Again, no errors encountered but the boot loop continues.

Any thoughts? I've also tried running the battery down to no avail.



Forum Legend
Message 2 of 5
Message 2 of 5

Re: Z3 Tablet stuck in bootloop

1. Charge the device 2-3 hours using the wall mount charger. Remove all accessories like SD card etc. Ignore. Boot loops
2. Try repairing again using Xperia companion. Preferably using another computer or a re installed one.

Learn to take care and troubleshoot your Device here:
Xperia Support by Sony:
Message 3 of 5
Message 3 of 5

Re: Z3 Tablet stuck in bootloop

According to Sony Xperia Z3 Manual to get rid of this issue do as following:

  1.  First of all switch off your tablet.
  2. Hold volume up and power for approx 10 seconds
  3. Start PC Companion .
  4. Choose Support zone then Update my phone/tablet then in Blue Repair my phone/tablet and follow the onscreen instructions.
  5. When prompted connect your phone still switched off holding volume down.This should start the repair or reformat process
  6.  If you are using Windows 8/8.1 or a 64bit operating system then adjust the settings for PC Companion and run in compatibility mode and chose Windows 7 or XP.

I hope this might fix your issue. For more deatils you can also check manual. 

Message 4 of 5
Message 4 of 5

Re: Z3 Tablet stuck in bootloop

I've had this problem.

I've tried to repair software using Xperia Companion for a few days, unsuccesfully.

I noticed same water condensation on the memory card when i removed it.

I put the device in a warm place with all the cover totaly open for few days, to evaporate internal water condensation.

I've tried to repair software using Xperia Companion, this time succesfully.

One time poster
Message 5 of 5
Message 5 of 5

Re: Z3 Tablet stuck in bootloop

Hi to all,


I'm having the same problem. The tablet is stuck in bootloop and unfortunately I cannot even use Xperia Companion cause it seems it needs Transfer Multimedia (MTP) to be accessible.


Moreover, there is a secure pattern mode so anyway I cannot do anything.


Any helps ? besides the "condensation problem", someone has got any solution with this kind of booloop problem ?


Thanks for your help Slightly smiling Face