account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

How to disable Music autostart when headset is plugged and without smartconnect ?

SOLVED
Highlighted
Apprentice
Message 1 of 9
60,658 Views
Message 1 of 9

How to disable Music autostart when headset is plugged and without smartconnect ?

Hi,

After rooting my Z3C and upgraded to .5.77 fw, i disabled some app packages via ADB, as "SmartConnect" (com.sonyericsson.extras.liveware) package. But i still have this boring music autostart when i connect my headset.
So anyone could tell me how disable once and for all this (Music on the go??) via ADB or freeze it via titanium backup ?
Thanks !!

1 ACCEPTED SOLUTION

Accepted Solutions
Apprentice
Message 3 of 9
93,223 Views
Message 3 of 9

Re: How to disable Music autostart when headset is plugged and without smartconnect ?

Thanks for your answer Uliwooly !

I did that, but autolaunch continued...

I finally found that their was also an option in my audio player (PowerAmp) i had to disable Thinking Face

Thanks again for your help !

8 REPLIES 8
Emperor
Message 2 of 9
60,651 Views
Message 2 of 9

Re: How to disable Music autostart when headset is plugged and without smartconnect ?

Settings > apps > all > smartconnect > clear data 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Apprentice
Message 3 of 9
93,224 Views
Message 3 of 9

Re: How to disable Music autostart when headset is plugged and without smartconnect ?

Thanks for your answer Uliwooly !

I did that, but autolaunch continued...

I finally found that their was also an option in my audio player (PowerAmp) i had to disable Thinking Face

Thanks again for your help !

Emperor
Message 4 of 9
60,618 Views
Message 4 of 9

Re: How to disable Music autostart when headset is plugged and without smartconnect ?

Anytime Slightly smiling Face 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

One time poster
Message 5 of 9
50,132 Views
Message 5 of 9

Re: How to disable Music autostart when headset is plugged and without smartconnect ?

Any ideas on how to do it with an M5 xperia?
Visitor
Message 6 of 9
46,706 Views
Message 6 of 9

Re: How to disable Music autostart when headset is plugged and without smartconnect ?

Sebsan64 : what was that Poweramp option? :-D
One time poster
Message 7 of 9
37,429 Views
Message 7 of 9

Re: How to disable Music autostart when headset is plugged and without smartconnect ?

Hi, once you plug in your headphones and the music starts playing, click on one of the two icons that appear on your display with a name "Smart Connect". Mine then appears as "Music at home." There change the settings or swith off the "event" (feature) completely.

One time poster
Message 8 of 9
31,473 Views
Message 8 of 9

Re: How to disable Music autostart when headset is plugged and without smartconnect ?

Great... Thank you uliwooly... You removed my one yr frustration.... Sony is such not at all user friendly I dont understand when he will change.. Even to kudo ur comment .. I need to do 5 long steps of activation.... 3rd world company....

One time poster
Message 9 of 9
9,152 Views
Message 9 of 9

Re: How to disable Music autostart when headset is plugged and without smartconnect ?

Go to Smart Connect app > select events > then disable the event music on the go.

Slightly smiling Face