account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Can't sync iPhoto albums with Sony Bridge for Mac

SOLVED
Learner
Message 1 of 20
2,681 Views
Message 1 of 20

Can't sync iPhoto albums with Sony Bridge for Mac

When I connect the Sony Xperia Z3 compact to the mac the Sony Bridge for Mac shows up. I select the option to explore iPhoto. At first nothing shows up (Sony developers, it would be nice to at least show a spinner or progress bar) but after a while events appear. However all other picture categories (faces, albums, pictures or last importation) don't show up.

 

Since I prefer to organize pictures by albums rather than events I can't sync anything, as I have no options to check. I'm using Sony Bridge for Mac 3.8.3(3831) and iPhoto 9.5.3 (902.17). Does somebody know how to solve this?

1 ACCEPTED SOLUTION

Accepted Solutions
Learner
Message 2 of 20
3,800 Views
Message 2 of 20

Re: Can't sync iPhoto albums with Sony Bridge for Mac

Huh, so it actually works, it is just painfully slow. After leaving the bridge app open for a while finally the albums appeared. Checking albums of about 3000 pictures is terribly slow but works. Unfortunately multiple separate albums are copied straight to the pictures folder rather than organised in subdirectories, so this feature is not very useful at all.
19 REPLIES 19
Learner
Message 2 of 20
3,801 Views
Message 2 of 20

Re: Can't sync iPhoto albums with Sony Bridge for Mac

Huh, so it actually works, it is just painfully slow. After leaving the bridge app open for a while finally the albums appeared. Checking albums of about 3000 pictures is terribly slow but works. Unfortunately multiple separate albums are copied straight to the pictures folder rather than organised in subdirectories, so this feature is not very useful at all.
Apprentice
Message 3 of 20
2,534 Views
Message 3 of 20

Re: Can't sync iPhoto albums with Sony Bridge for Mac

I have left the Sony Bridge for Mac open for a half hour but nothing shows up in the iPhoto section. Since I do not see anything from iPhoto I am not able to sync pictures.

 

I have Xperia Z3 Compact with latest software, Sony Bridge for Mac 3.8.3(3831). I also uninstalled Bridge and reinstalled it. Still nothing shows up.

 

Any suggestions?

Apprentice
Message 4 of 20
2,514 Views
Message 4 of 20

Syncing photos to iPhoto not working with Sony Bridge for Mac

I have the latest Sony Bridge for Mac. Mac OS X 10.9.4 on my Mac. In Sony Bridge for Mac I click on iPhoto Library but it does not show any content. Am I the only one with this problem?

 

I have tried to reinstall Sony Bridge but no help.

Talent
Message 5 of 20
2,502 Views
Message 5 of 20

Re: Syncing photos to iPhoto not working with Sony Bridge for Mac

Hi Asle!

 

I'm very sorry to hear that you have a problem with BFM.

I will try to help but I need some more information.

 

(1) The build number of your phone

(2) The android version you are using

(3) The version of iPhoto

 

It would also be very nice if you can send me the error logs.

Here’s how to get error logs from Sony Bridge for Mac:
1. In BfM, hold the "alt" key down while selecting the "Phone" menu. Select "Clear logs" to remove all old logs and get a clean start
2. Reproduce the problem you're having, whether it's connecting the phone, importing photos, doing backup...
3. In BfM, hold the "alt" key down while selecting the ”Xperia” menu. Select "Export logs"
4. On the computers desktop there should now be a file named "SonyBridgeForMacLogs_[date].zip
5. PM that file to me


Best regards


Fredrik

Apprentice
Message 6 of 20
2,478 Views
Message 6 of 20

Re: Syncing photos to iPhoto not working with Sony Bridge for Mac

Modellnumber: D5803

Buildnumber: 23.0.A.2.93

 

Android 4.4.4

 

iPhoto: 9.5.1 (902.17)

Mac OS X 10.9.5

 

Will PM the logfile.

Thanks!

 

~asle

Talent
Message 7 of 20
2,464 Views
Message 7 of 20

Re: Syncing photos to iPhoto not working with Sony Bridge for Mac

Hi Asle!

 

Thank you for the log files.

 

I have sent them to the development crew.

 

I will write hear when I get an answer back from the development crew.

 

Best regards

 

Fredrik

 

Talent
Message 8 of 20
2,449 Views
Message 8 of 20

Re: Syncing photos to iPhoto not working with Sony Bridge for Mac

Hi Asle!

 

I have send your logs to the development crew but they can't see anything strange.

 

Can you try this:

make sure you don't remove it from it's place
- Go to Finder
- Select Go->Go to Folder...
- Paste
~/Library/Preferences/
in the dialog and press Go
- In the folder that pops up in the Finder, locate the file named "com.apple.iApps.plist"
- Copy and send a pm to me (make sure you don't remove it from it's place)

 

Best regards

 

Fredrik

 

Highlighted
Apprentice
Message 9 of 20
2,412 Views
Message 9 of 20

Re: Syncing photos to iPhoto not working with Sony Bridge for Mac

Still no success with iPhoto. Did you find out anything Fredrik?

 

I checked the apple.com.iApps.plist and it looks correct. When I open iPhoto the correct library is opened. Strange that SBFM finds my iTunes library but not my iPhoto library. I recall that I was able to see the iPhoto library the first time I installed SBFM but not since then. I have trashed SBFM preference files but without any success.

Talent
Message 10 of 20
2,385 Views
Message 10 of 20

Re: Syncing photos to iPhoto not working with Sony Bridge for Mac

Hi Asle!

 

Sorry for the time it's taking.

 

I got a message from one in the development crew that had a similar problem.

 

He wrote this:

 

I had the same issue after rollbacking my OS X to one Time Machine backup.

These steps fixed it for me:

1) Open iPhoto and check that the pictures and events and so on are there.

2) Restart your computer.

I couldn't exactly check what was happening, but my guess is that after a rollback or a migration, the iPhoto library references are the old ones, and it is not until you open at least once you iPhoto software that those references get updated.

 

If it doesn't work please contact me again.

 

Best regards

 

Fredrik