account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Bluetooth issues with 6.0.1 and Pebble Time

Highlighted
Adviser
Message 1 of 15
2,798 Views
Message 1 of 15

Bluetooth issues with 6.0.1 and Pebble Time

Since updating to 6.0.1, I have found that after a while, notifications stop being sent to my Pebble watch. Restarting the Pebble does nothing, but turning off and on the Bluetooth on the phone fixes the issue.
The problem is, I have to do this perhaps once every 3 hours or so as it keeps happening.

This never happened before the update, so definitely looks like a Bluetooth issue. I checked and made sure that the Pebble application is not using battery or data optimisation.
Any ideas on how to solve? Or is this just going to have to wait for an update again?
Super annoying as I'm missing a lot of calls and messages.
Mo Jiwa
14 REPLIES 14
Emperor
Message 2 of 15
2,772 Views
Message 2 of 15

Re: Bluetooth issues with 6.0.1 and Pebble Time

@mojiwa

 

do you have stamina on (on your Z3 Compact)?




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Adviser
Message 3 of 15
2,767 Views
Message 3 of 15

Re: Bluetooth issues with 6.0.1 and Pebble Time

Nope. No power saving options on at all
Mo Jiwa
Adviser
Message 4 of 15
2,733 Views
Message 4 of 15

Re: Bluetooth issues with 6.0.1 and Pebble Time

I've now tried uninstalling and reinstalling the pebble application; disconnecting the pebble device from the bluetooth devices and readding it... still, no dice. 

I really think there's something wrong on the Sony side.

Mo Jiwa
One time poster
Message 5 of 15
2,606 Views
Message 5 of 15

Re: Bluetooth issues with 6.0.1 and Pebble Time

Same thing for me and my Pebble Time Steel, I have tried the same things as you, but to no avail. I went through Pebble's support and they told me it's a problem on Sony's side
Adviser
Message 6 of 15
2,598 Views
Message 6 of 15

Re: Bluetooth issues with 6.0.1 and Pebble Time

I went through Sony support. First they suggested I completely reset the phone, which I've done - still no luck.

Then they told me I should send it for repair... but I highly doubt that will make any difference.

What is really interesting is that when it stops notifying, the watch can still control the phone. I can still adjust volume, change tracks, all that - but the watch doesn't update with whatever the phone is doing. 

 

I also find that restarting the phone means it will work for about 2 days before stopping, whereas turning off and on bluetooth may only work for some hours.

Mo Jiwa
Adviser
Message 7 of 15
2,565 Views
Message 7 of 15

Re: Bluetooth issues with 6.0.1 and Pebble Time

Hey JonyP, 

just out of interest, which watchface are you using on your Pebble?

 

I was using TimeStyle, but since yesterday decided to move back to 91 Dub v4.0. 

Every now and then, the watch buzzes like it's been disconnected, but still stays connected. I think it's retrying to connect when the bluetooth gets knocked out. As a result, notifications seem to keep working.

 

The problem is definitely on the Sony side, but this watchface seems to have a design feature that works around the issue. 

You might want to try it. So far, it seems to work, but I'll post on here if it stops working for me.

Mo Jiwa
One time poster
Message 8 of 15
2,450 Views
Message 8 of 15

Re: Bluetooth issues with 6.0.1 and Pebble Time

I've had the same issues and have tried several watchfaces. I *think* that Sliding Time Weather is working OK though...4 days without losing notifications. I was using TimeStyle and Street and both of those suffered from notifications only lasting a few hours. 

 

Maybe we could compile a list of watchfaces that seem to work?

Adviser
Message 9 of 15
2,441 Views
Message 9 of 15

Re: Bluetooth issues with 6.0.1 and Pebble Time

Mine did work for a while... but now it's just as bad as it was previously.

I'm going to be getting the new Sony Xperia anyway, so hopefully it won't be an issue there. 

Also, now that Pebble is no more, I'll be looking for a new Smartwatch too. haha

Mo Jiwa
Message 10 of 15
2,422 Views
Message 10 of 15

Re: Bluetooth issues with 6.0.1 and Pebble Time

I don't want to get over excited but I appear to have fixed this issue with a "Software repair" via Xperia Companion.  In chat with Sony support they said, in brief:

You can download this here: http://www-support-downloads.sonymobile.com/Software%20Downloads/Xperia%20Companion/XperiaCompanion....
Open Xperia Companion and go to Software Repair. At this point there will be some on screen steps for you to follow, please do not connect the handset until you are prompted to do so.

Just to be clear, I agree with other posters that this issue came after the 6.0.1 OTA update and an on-board factory reset (in fact two) did not resolve it. Using Xperia Companion appears to have cleared it up completely.

 

It's a full factory reset, so I had to reinstall everything, but very much worth it to have my Pebble back to its old self. Hope this helps someone else.