account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Audio Jack 3.5 mm Problem

Rookie
Message 1 of 10
8,848 Views
Message 1 of 10

Audio Jack 3.5 mm Problem

I have several audio systems that I want to connect to my z3 compact via the 3.5mm audio jack, but the majority of the cables I have do not connect it. The sound just remains going through the Z3's speakers, or in one instance it assumed it was a microphone . These all worked with my old HTC phone. Does the Sony require a longer plug, if so where can I buy one? Or is it faulty? Is anyone else having similar issues?

9 REPLIES 9
Emperor
Message 2 of 10
8,844 Views
Message 2 of 10

Re: Audio Jack 3.5 mm Problem

That's odd, have you try the basic, restart the phone, if its a regular headphone or 3.5mm cable should work, unless the headphones have any type of control, then you will need a 3.5mm 5 pole audio contact 

 

 

http://www.xperiablog.net/2014/03/09/sony-mdr-nc31em-digital-noise-cancelling-headset-now-in-stock/

 

 

 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Rookie
Message 3 of 10
8,760 Views
Message 3 of 10

Re: Audio Jack 3.5 mm Problem

Restarting has no effect. Some standard jacks register as headphones, some do not. Even one of the leads I have disconnects mid use. A four pole cable does not work, whereas a  A pair of Beats with a mic with an inline control and 4 poles does (although controlling spotify requires the app to present in the lock  screen which it isn't always! All very annoying, no in car use, can't connect to hifi etc.

 

Can one purchase a 5 pole connector to two phonos or another 3.5mm jack, although not sure this will help? I think it may be  the Smart Connect App cocking it up. I am considering force stopping this to see if that helps.

 

Anyone else have similar issues?

Highlighted
Inhabitant
Message 4 of 10
8,742 Views
Message 4 of 10

Re: Audio Jack 3.5 mm Problem

Yeah, 5 poles are only needed for the noise cancelling headphones, AFAIK; all my 4 pole headsets with inline controls that are made for Android work just fine; I can't find any 3 poles that don't work or aren't recognised as headphones (even Apple's standard buds are OK), but that's not saying anything unless we're both testing the same cables Slightly smiling Face

 

I'd try resetting the Smart Connect data via Apps > Smart Connect > Clear data, and if that doesn't work maybe take to Sony to have a look at.

 

Rookie
Message 5 of 10
8,721 Views
Message 5 of 10

Re: Audio Jack 3.5 mm Problem

Thanks for replying.. Have tried clearing Smart Connect data but to no effect. The problem appears to occur with connecting cables (to connect to the car or a hifi) it so far hasn't occured with headphones. I have even had the phone assume I was connecting a microphone.I have seen another post regarding a Z or Z1 which said that connecting a splitter and plugging in headphones on one side and using the other to output  works, but that is hardly an elegant solution.

 

I  have downloaded Sound About app which has a widget which so far  does work but I need to experiment more with it as the  this morning it  silenced BBC iplayer when I docked the phone.

 

It seems rather poor to have to rely on a third party app to solve something so basic. I think that Smart Connect is much more trouble than it's worth, at least for how I want to use the phone, either it should be updated so that it senses connecting cables as headphones or why not at least add the option of turning it off and having a manual override widget. Sony?

Emperor
Message 6 of 10
8,634 Views
Message 6 of 10

Re: Audio Jack 3.5 mm Problem

You might want to contact Sony directly

 

http://www.sonymobile.com/global-en/support/contact-us/




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

One time poster
Message 7 of 10
8,266 Views
Message 7 of 10

Re: Audio Jack 3.5 mm Problem

Hi guys... I bought my Xperia 2 weeks ago and I got a problem since wednesday. When I put the headphones into the jack, only the left channel is working.. and there's no sound in right... What to do? (I've read for Smart Connect, but it's not working) Thank you

One time poster
Message 8 of 10
7,051 Views
Message 8 of 10

Re: Audio Jack 3.5 mm Problem

hi, could you fix it? i have the same problem with my z3 compact.

One time poster
Message 9 of 10
6,944 Views
Message 9 of 10

Re: Audio Jack 3.5 mm Problem

I have the same problem with my z3c.

The problem isn't from various cables, problem is with your 3,5mm in your phone.

One day a friend of mine, who also has z3c, came to my place, and the cable that didn't work with my phone worked with his phone. And that got me thinking Slightly smiling Face

And the funny thing is, the cable was Sony certified x) The irony.

So use your waranty and fix this.

One time poster
Message 10 of 10
5,031 Views
Message 10 of 10

Re: Audio Jack 3.5 mm Problem

Just get an OMTP to CTIA adapter, Sony unfortunatelly firstly supported OMTP then jumped ship to be compatible with apple and older jacks don't work with new Sony devices, it's annoying .