account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

wifi hotspot stoped working

SOLVED
fbs
Apprentice
Message 1 of 13
7,455 Views
Message 1 of 13

wifi hotspot stoped working

Hi there!
I've found a problem with last system update for my smartphone: Android hotspot doesn't allow to access Internet.

The version of the update is 23.0.1.A.3.9

I've seen that the wifi connection between PC and phone works fine (in fact, if a server is mounted on phone, the PC finds it and can connect to the server) and the connection from the phone to another hotspot works, but if the node is the phone, the tunnelling between mobile data connection and wifi network, doesn't work (as no route is made!), so, PC connects to phone, but can't access to the Net.

This happens with Bluetooth too! No wireless hotspot is possible, but they was on prior versions.

This terminal hasn't rooted, so I can't modify routes nor iptables, etc...
1 ACCEPTED SOLUTION

Accepted Solutions
Sony Xperia Support
Message 6 of 13
11,321 Views
Message 6 of 13

Re: wifi hotspot stoped working

As it worked before the update i suspect that the issue is that your internet settings have been reset which may happen when you update. If your subscription doesn't support tethering it should not have worked before the update but i still recommend that you check it.

 

I googled for Movistar and this and found a topic where it seems someone from Movistar has posted the settings you need. Perhaps this thread may help you: http://comunidad.movistar.es/t5/Soporte-T%C3%A9cnico-Terminales/No-funciona-el-tethering-a-partir-de...

 

With some phones you can use tethering even if the subscription does not allow it. With older versions of Android it's possible for example. But with later versions the phone makes another connection for the tethering which is why your subscription must support it and you need correct APN-settings for tethering.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

12 REPLIES 12
fbs
Apprentice
Message 2 of 13
7,453 Views
Message 2 of 13

Re: wifi hotspot stoped working

Ah! I forgot to mention that I tried to repair with PC Companion, and the result was the same, so the problem is on the update!
Sony Xperia Support
Message 3 of 13
7,413 Views
Message 3 of 13

Re: wifi hotspot stoped working

Hi and welcome to the community! Since you're new please be sure that you have checked out our Discussion guidelines.

 

This happens if your subscription doesn't allow tethering or if you don't have the correct APN settings in your phone for tethering. Many operators use special APN-settings for tethering so the default internet settings will not work in many cases.
I recommend that you contact your operator to make sure that your subscription supports tethering and to check what APN settings you need for this. Then add them under Settings -> More -> Mobile networks -> Access Point Names.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

fbs
Apprentice
Message 4 of 13
7,405 Views
Message 4 of 13

Re: wifi hotspot stoped working

Thxs for your reply. My provider accepts thetering (movistar spain) 'cause other phone on the same company (but different aechitecture, IOS) allows the connection, and the configuration is the same I have (autoconfigured by provider's downloader).
So, the problem should be on the update, shouldn't it?
fbs
Apprentice
Message 5 of 13
7,400 Views
Message 5 of 13

Re: wifi hotspot stoped working

Another point: The data connection (4g/h/g icon) shows a sword when sending/receiving data (this did prior versions when tethering) and now, when tethering it doesn't appears
Sony Xperia Support
Message 6 of 13
11,322 Views
Message 6 of 13

Re: wifi hotspot stoped working

As it worked before the update i suspect that the issue is that your internet settings have been reset which may happen when you update. If your subscription doesn't support tethering it should not have worked before the update but i still recommend that you check it.

 

I googled for Movistar and this and found a topic where it seems someone from Movistar has posted the settings you need. Perhaps this thread may help you: http://comunidad.movistar.es/t5/Soporte-T%C3%A9cnico-Terminales/No-funciona-el-tethering-a-partir-de...

 

With some phones you can use tethering even if the subscription does not allow it. With older versions of Android it's possible for example. But with later versions the phone makes another connection for the tethering which is why your subscription must support it and you need correct APN-settings for tethering.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

fbs
Apprentice
Message 7 of 13
7,384 Views
Message 7 of 13

Re: wifi hotspot stoped working

I apologize. You was right. Android versions prior 4.1.2 seems that the DUN connection type was "standard" and no need to identificate it, but newer versions doesn't allow this, and after the upgrade, bye bye tethering.

Thank you very very much. Adéu!
Rookie
Message 8 of 13
7,324 Views
Message 8 of 13

Re: wifi hotspot stoped working

Hi,  am having same problem, sony z2, tethering was working fine. Called three, all ok on their side. Repaired using pc companion still no good, downloaded Internet settings, nothing. Tried my sim card in a sony z1 compact phone and it worked! So has to be firmware on z2?

fbs
Apprentice
Message 9 of 13
7,316 Views
Message 9 of 13

Re: wifi hotspot stoped working

Alf123, maybe the problem is the same I had and Rikard solved (well, he found the solution on movistar website ;-))

It seems that prior versions of Android puts the Dial Up Network property on APN's type as default, but on upgrades, this configuration is deleted, and so, the tethering stops working. Curiously, reinstalling the providers config can be unsuccessful (the property isn't configured).

Try the next: Go to your provider's APN, and on APN type add DUN (ex. Type of apn: default, mms, dun) and try this config. Maybe you should to reboot the device prior to work.
Highlighted
Rookie
Message 10 of 13
7,204 Views
Message 10 of 13

Re: wifi hotspot stoped working

Genius, this is why I come here. Got a link to 3 settings, it's worked for me :-)

http://www.geeksquad.co.uk/articles/three-apn-settings#3%20Three%20Android%20APN%20MMS%20mobile%20in...