account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Z2(D6502) speaker and microphone NOT working

One time poster
Message 1 of 3
1,702 Views
Message 1 of 3

Z2(D6502) speaker and microphone NOT working

Hello,

 

My Z2's microphone and speaker have suddenly stopped working.

 

1) Can't play any sound for music and videos, or cannot hear anything during calls.

2) Microphone also won't work, as I can't record my voice, nor can anyone hear my voice on calls.

3) Also, it won't even recognise headset or earphones Slightly frowning Face

 

I have tried rebooting in safe mode, and even repaired with PC companion, but nothing helped Slightly frowning Face Is this hardware or a software issue?

2 REPLIES 2
Sony Xperia Support
Message 2 of 3
1,670 Views
Message 2 of 3

Re: Z2(D6502) speaker and microphone NOT working

Hi @sankarshan, welcome to the community. I am sorry to hear about this issue Slightly frowning Face

As the software repair using Xperia Companion has not resolved the issue then I recommend you contact your Local support team to arrange a repair.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Highlighted
One time poster
Message 3 of 3
178 Views
Message 3 of 3

Re: Z2(D6502) speaker and microphone NOT working

How do I turn on the microphone?. I think I turned it off in error.