account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Problem with incoming calls

Visitor
Message 1 of 9
4,884 Views
Message 1 of 9

Problem with incoming calls

Since the latest software uppdating, I cannot answer incoming calls. The phone is ringing but no botton for answering shows up. Thank you for help, urgent!

8 REPLIES 8
Forum Legend
Message 2 of 9
4,876 Views
Message 2 of 9

Re: Problem with incoming calls

Try performing a system repair as this will often fix issues after an upgrade - This will factory reset your phone

Switch off your phone and unplug from Pc (Hold volume up and power for around 10 seconds)
Start PC Companion and select Support zone then Update my phone/tablet then in Blue Repair my phone/tablet and follow the onscreen instructions - When prompted connect your phone still switched off holding volume down or back button - This should start the repair or reformat process

If you are using Windows 8/8.1 or a 64bit operating system then adjust the settings for PC Companion and run in compatibility mode and chose Windows 7 or XP

For a successful technology, reality must take precedence over public relations, for Nature cannot be fooled.   Richard P. Feynman



Visitor
Message 3 of 9
4,873 Views
Message 3 of 9

Re: Problem with incoming calls

The problem is solved!

One time poster
Message 4 of 9
4,239 Views
Message 4 of 9

Re: Problem with incoming calls

Hi, I am having the same problem but unable to connect to a computer.
Is there any other way this may be done? :-)
Genius
Message 5 of 9
4,203 Views
Message 5 of 9

Re: Problem with incoming calls

If the screen remains black when the phone rings go to Settings - Apps & swipe along to ALL then scroll down to InCallUI & enable.....:smileysmileywink:

Learner
Message 6 of 9
4,032 Views
Message 6 of 9

Re: Problem with incoming calls


@dandy63 wrote:

If the screen remains black when the phone rings go to Settings - Apps & swipe along to ALL then scroll down to InCallUI & enable.....:smileysmileywink:



Hi, following your information I found that there is only the force stop bottom in my mobile.

Have you got any other idea of what could be causing the problem ??

Thanks in advace

Learner
Message 7 of 9
4,005 Views
Message 7 of 9

Re: Problem with incoming calls

Hi everyone.

Just a little update,  I finally got to solve the problem with my Z2.

Go to Settings,  Personalisation,  Manage notifications and make sure that the "Phone" is ticked, you might be able to see the "InCallUI" there as well and it should also be ticked.

Hope it helps.

Inhabitant
Message 8 of 9
2,747 Views
Message 8 of 9

Re: Problem with incoming calls

HELLO:  I would like  very much to share  my experience of NO incoming phone  ring volume .   I have  the problem solved finally.  In the past few  weeks, I got NO ring VOLUME but the Sound and Notification's RING volume was at its MAX level. I tapped on it, and got NO  sound.  ALl incoming call activated the vibration but NO RING TONE.  Finally I found out  EXACTLY which APPS  caused this problem.  It  was the  WECHAT VOICE call option.    During WECHAT VOICE MODE, the righ tone is compressed and I got notification thru vibration and a display is open on the top of the phone for me to answer or decline.  After finishing the  WECHAT voice mode, WECHAT did not  close this feature probably and the volune ring tone  was still in the compressed mode. That  was WHY the  ring tone was SHUT OFF  every time  after my WECHAT session.   To solve this problem is  to  POWER OFF  and  then POWER ON  again  everytime after the wechat voice session.  This  solved  my problem.  IF  anyone is  using  the  WECHAT Voice feature, and  get  NO incoming call ring tone,  this  may be  your  problem. thank You for listening.

Highlighted
One time poster
Message 9 of 9
550 Views
Message 9 of 9

Re: Problem with incoming calls

I cant answer my phone normarly. When I receive a call there is phone sign at the top left of my phone.