account arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-down

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Gap issue, fixed?

SOLVED
Inhabitant
Message 1 of 26
Message 1 of 26

Gap issue, fixed?

I really love sony, the phones are simply beautiful and the UI is amazing! I was considering buying a Z2 but users have reported having gaps between their screens and the metal covering on the sides, sony did tell them to get a waterproof test from a sony center but i want to know if anyone had the problem and got the test, was it still waterproof? Has sony fixed this in their new upcoming Z2 devices or is it still there? Should i get Z2 or not?

1 ACCEPTED SOLUTION

Accepted Solutions
Message 2 of 26
Message 2 of 26

Re: Gap issue, fixed?

I would recommend waiting a week or so. Sony fixed the issues in newer batches (14W21 onwards). If you're going to buy the Xperia Z2 then make sure you check the device thoroughly before buying it and check the batch number by pulling out the Micro SD tray on the right hand side. 

 

Remember, gaps can be very minimal and can take a lot of time to notice. I noticed the gaps in my phone a week after getting it.

 

Gaps shouldn't really affect waterproofing because the seal is made over a large area.

 

EDIT: I wish my ever so focusing eyes hadn't noticed the gaps and I wish I had checked the device insead of just taking the box and paying for it. I have batch 14W20 and camera doesn't heat up as much as others

25 REPLIES
Message 2 of 26
Message 2 of 26

Re: Gap issue, fixed?

I would recommend waiting a week or so. Sony fixed the issues in newer batches (14W21 onwards). If you're going to buy the Xperia Z2 then make sure you check the device thoroughly before buying it and check the batch number by pulling out the Micro SD tray on the right hand side. 

 

Remember, gaps can be very minimal and can take a lot of time to notice. I noticed the gaps in my phone a week after getting it.

 

Gaps shouldn't really affect waterproofing because the seal is made over a large area.

 

EDIT: I wish my ever so focusing eyes hadn't noticed the gaps and I wish I had checked the device insead of just taking the box and paying for it. I have batch 14W20 and camera doesn't heat up as much as others

Inhabitant
Message 3 of 26
Message 3 of 26

Re: Gap issue, fixed?

Thanks a lot! Yeah i might be actually waiting a month before getting or at least a week for sure. Thanks a lot for the additional information about the branding numbers smile happy

Demigod
Message 4 of 26
Message 4 of 26

Re: Gap issue, fixed?

I don't think you have to wait anymore. the 1st few batches has been long released and gone to the first few countries. Now, it should alreadt be at the 7th, 8th, 15th batch already. laugh

Genius
Message 5 of 26
Message 5 of 26

Re: Gap issue, fixed?

Just to clarify is it ALL batches up to 14W21 that had quality issues ie gaps???? I have 14W16 and it looks perfect......possibly just a small minority of a certain batch having build quality problms?

 

Thanks

Demigod
Message 6 of 26
Message 6 of 26

Re: Gap issue, fixed?

Not true.There are actually very few issues. The rest are just perception. It's like if someone post and say that their phone is not black but dark grey, then you will start seeing similar posts claiming the same. It's a chain reaction. Much like Lemmings (awww i miss that game) . Then someone will try to be smart and say that it's 80% black and what not.

 

Sometimes, reading posts are not fun enough. They start wanting to be part of it. smile green

Commissioner
Message 7 of 26
Message 7 of 26

Re: Gap issue, fixed?

Mine is 14W16 for Europe, and has no gaps in chasis. Also the covers are steady and in place after month of charching, connecting. It would be a market place issue, the first batch went to india and there the gaps were found, markets released later should be already fixed on production stage.

> Give cudos or mark as solution if helped, give others a chance to find it.
Genius
Message 8 of 26
Message 8 of 26

Re: Gap issue, fixed?

As is mine....no gaps/covers fit snuggly thumbs up

Commissioner
Message 9 of 26
Message 9 of 26

Re: Gap issue, fixed?

I suspect I have small gaps although it doesn't bother me too much - the screen goes crazy registering touches when a droplet of water hits it anyway.

 

Out of interest, where do I find the batch code? I checked the box and About Phone in settings...

 

EDIT: I have 14W19 and gaps a described per this link: http://forum.xda-developers.com/showthread.php?t=2757544 

Genius
Message 10 of 26
Message 10 of 26

Re: Gap issue, fixed?

Re 'batch code/....if you dismount the SD CARD thru Settings, safely take it out and there is also a thin tray that you can pull out...bit fidgity and make sure you note what way it sits ie what side up....underneath the tray are various codes etc...batch number is there wink

 

If you have the 'GLOVE MODE' selected in Settings try turning it off and see if there is any difference...

 

Good luck smile happy