account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Can't turn on my Z2 tablet

One time poster
Message 1 of 1
1,491 Views
Message 1 of 1

Can't turn on my Z2 tablet

When I try to turn it on it stucks in a loading screen, left it for a night - still loading. No problems with charging though.

I tried to reset it with Xperia Companion, but Windows recognises it as Unknown USB Device (Device Descriptor Request Failed). If I press a Volume-Down button before connecting it still identifies it as the same Unknown Device.

If I press a Volume-Up, it gets recognised as S1Boot Fastboot, but I'm not sure what to do with this. Tried to download Xperia drivers and apply them to this device, but no luck, it still isn't recognised by Xperia Companion, so I can't run its Software Repair procedure.

I've tried all of the above with a fully charged device.

 

The problem started when the tablet gets discharged, plus it was rebooting at the same time. So my guess is a software problem (something was rewritten in system files, and it can't start normally).

Is there any way to hard reset it with some tablet key combination?