account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Xperia z1 can not turn on but still show LED red light

SOLVED
Learner
Message 1 of 12
30,727 Views
Message 1 of 12

Xperia z1 can not turn on but still show LED red light

Yesterday my Xperia z1 was hot and got turn off, i thought it ran out of battery. So I charged my phone and it show blink red led light then I unplug my phone after 1 hour and started pushing power button but it did not turn on. I tried to hard reset like push power+volume up, physical reset with red button but it still turn off.

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator
Message 8 of 12
40,225 Views
Message 8 of 12

Re: Xperia z1 can not turn on but still show LED red light

Take the phone into service,the motherboard could be faulty.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

11 REPLIES 11
Demigod
Message 2 of 12
30,706 Views
Message 2 of 12

Re: Xperia z1 can not turn on but still show LED red light

Hi there,

 

Press and hold "Power Button" and "Volume Up" at the same time about 8 seconds(3 vibrations) =Force Shutdown.

 

Charge your phone 1 hour and then try to repair using Sony Update Service.

 

 

Cheers.

 

 

There is nothing impossible to him who will try.  A. t. G. (356BC - 323BC)

Learner
Message 3 of 12
30,694 Views
Message 3 of 12

Re: Xperia z1 can not turn on but still show LED red light

It does not work any more. When I plug my phone to computer it was not response to Update service program.

Demigod
Message 4 of 12
30,692 Views
Message 4 of 12

Re: Xperia z1 can not turn on but still show LED red light

Do you get any response from the phone at all when you try to charge it?

There is nothing impossible to him who will try.  A. t. G. (356BC - 323BC)

Highlighted
Learner
Message 5 of 12
30,689 Views
Message 5 of 12

Re: Xperia z1 can not turn on but still show LED red light

It only show blink red LED light.

Demigod
Message 6 of 12
30,686 Views
Message 6 of 12

Re: Xperia z1 can not turn on but still show LED red light

Put it on the charger for 2 hours and wait the response.

 

Your battery is almost discharged, then try again.

There is nothing impossible to him who will try.  A. t. G. (356BC - 323BC)

Learner
Message 7 of 12
30,662 Views
Message 7 of 12

Re: Xperia z1 can not turn on but still show LED red light

It does not work.

Moderator
Message 8 of 12
40,226 Views
Message 8 of 12

Re: Xperia z1 can not turn on but still show LED red light

Take the phone into service,the motherboard could be faulty.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

One time poster
Message 9 of 12
22,557 Views
Message 9 of 12

Re: Xperia z1 can not turn on but still show LED red light

Same thing just happened to my xperia. Red button flashing, wont turn back on. I tired hard reset. Still not working. Must be a command faulty problem. Ive only had the phone for a couple months, Very disappointed with Sony.

Apprentice
Message 10 of 12
10,251 Views
Message 10 of 12

Re: Xperia z1 can not turn on but still show LED red light

Same here. Unfortunately I bought my phone from 'Toby deals' which I presume is in China and when sent in to the uk Sony repair agent, they refuse to repair it, stating that it was not bought in the uk. I am not sure where I stand now, as it was in warranty when it went faulty and now it isn't. 

I just want it repaired and working. I've been a life long Sony man and now am beginning to lose loyalty.

Any advice, or help, is appreciated please guys?