account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Good day I purchased a sony xperia z1 c6903 device 2 weeks ago. Everything works fine but it never

Highlighted
One time poster
Message 1 of 2
652 Views
Message 1 of 2

Good day I purchased a sony xperia z1 c6903 device 2 weeks ago. Everything works fine but it never

My sony z1 c6903 won't go on LTE

Only supports H+

Tried updating OS to Lollipop

Changing Sim cards. Sim works fine and supports 4G in other devices.

1 REPLY 1
Sony Xperia Support
Message 2 of 2
587 Views
Message 2 of 2

Re: Good day I purchased a sony xperia z1 c6903 device 2 weeks ago. Everything works fine but it ne

Hi @Owina, sorry to hear about this. Slightly frowning Face

Could you please check if the network mode is set to 4G/LTE? You can find this setting in Settings > More > Mobile networks > Preferred network type.

If you still aren't able to get a 4G connection, could you please get back to me in a private message with your IMEI number? Open up my profile and tap on "Send message" in the top right corner.

Thank you.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.