account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

problems with the launch of the camera

SOLVED
Learner
Message 1 of 12
3,218 Views
Message 1 of 12

problems with the launch of the camera

Camera is operating normally, but even before, until you start to record video. That is, the recorded video, went to watch the video in the "Video", then you come back and see it backXHmseF6Jz5g.jpg

 

Is treated briefly by a reboot. Factory data reset doesn't help

 

P.S. I am sorry for my bad english

1 ACCEPTED SOLUTION

Accepted Solutions
Sony Xperia Support
Message 5 of 12
4,088 Views
Message 5 of 12

Re: problems with the launch of the camera

Hi iop258,

 

Welcome to the community,

 

Here is how the software repair is done on PC and Mac.

 

Here's how to run the repair on PC Companion:
1. Install and open PC Companion then select Support Zone.
2. Phone Software Update.
3. Start.
4. Repair Phone
5. Continue
6. Accept data removal
7. Next
8. Wait for prepare
9. Select Phone
10. Follow the connection steps

And Bridge for Mac:
1. Launch Bridge for MAC without the handset connected.
2. On the Main Window select "Xperia > Repair Xperia Device".
3. Ensure the phone is charged and select "Ok" in the following window.
4. Select Continue on the following page.
5. Wait until the initialising step is finished the continue as below.
6 . Select your model of phone from the list that appears
7. Follow the connection steps that appear, ensuring that you are holding the relevant button down before during and after the connection phase until the update/repair begins.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

11 REPLIES 11
Moderator
Message 2 of 12
3,215 Views
Message 2 of 12

Re: problems with the launch of the camera

So you have performed a factory settings reset? What about repair with PCC?



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

Learner
Message 3 of 12
3,205 Views
Message 3 of 12

Re: problems with the launch of the camera

What I forgot to mention, this began to happen after updating to Android 5.0.2 to 5.1.1

Emperor
Message 4 of 12
3,196 Views
Message 4 of 12

Re: problems with the launch of the camera

@iop258

 

Reinstall the latest update with PCC and report back

 

 

PC Companion (PCC)

 

 

Bridge (for Mac)

 

 

 

Alternatives on How to backup Xperias

 

http://talk.sonymobile.com/thread/36355

 

 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Sony Xperia Support
Message 5 of 12
4,089 Views
Message 5 of 12

Re: problems with the launch of the camera

Hi iop258,

 

Welcome to the community,

 

Here is how the software repair is done on PC and Mac.

 

Here's how to run the repair on PC Companion:
1. Install and open PC Companion then select Support Zone.
2. Phone Software Update.
3. Start.
4. Repair Phone
5. Continue
6. Accept data removal
7. Next
8. Wait for prepare
9. Select Phone
10. Follow the connection steps

And Bridge for Mac:
1. Launch Bridge for MAC without the handset connected.
2. On the Main Window select "Xperia > Repair Xperia Device".
3. Ensure the phone is charged and select "Ok" in the following window.
4. Select Continue on the following page.
5. Wait until the initialising step is finished the continue as below.
6 . Select your model of phone from the list that appears
7. Follow the connection steps that appear, ensuring that you are holding the relevant button down before during and after the connection phase until the update/repair begins.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Rookie
Message 6 of 12
3,089 Views
Message 6 of 12

Re: problems with the launch of the camera

I have problems with the camera as well after the 5.1 upgrade. First time I launch the camera, it's all okay. But when you start viewing your photos directly from the camera app (tapping the photos on the lower right if in landscape) and go back to the camera app, I get the "Camera not available" error. The error doesn't go away until power cycle. I also get an error with video playback. Fast forwarding the video gives me the "Video cannot be played" error. and also goes away only after power cycle. I did clean install, then repaired thru PCC after I got the camera errors. Still getting the same error after.

 

I hope Sony looks into this. Or if I can downgrade back to 5.0.

Inhabitant
Message 7 of 12
3,041 Views
Message 7 of 12

Re: problems with the launch of the camera

I have the exact same problem as xiaokhat (camera and video playback) except I don't get the "Camera not available" error message.
Furthermore if I open the camera, take 2 or more photos then close the camera, the moment I launch the camera again I get a black screen like the one posted by iop 258 and the camera becomes unusable until the phone is rebooted. Instead opening the camera, taking only one photo than closing the camera does not cause the problem as long as you take only one picture than close the camera.
Regarding the video playback issue I have no idea if it's connected with the camera's problem.

In summary:
1) open camera-->take 1 photo-->close camera: no problem
2) open camera-->take 2 or more photos (or go to album app from camera)-->close camera: the camera freezes when launched again

I tried performing a software repair with PCC without solving this problem. This began to happen after upgrading to Android 5.1.1 from 5.0.2

Adept
Message 8 of 12
2,878 Views
Message 8 of 12

Re: problems with the launch of the camera

I can confirm that the problem occurs when taking 2 or more photos (or go to album app from camera)-->close camera: the camera freezes when launched again

This began to happen after upgrading to Android 5.1.1

 

a software repair with PCC does not solve this problem.

Sage
Message 9 of 12
2,863 Views
Message 9 of 12

Re: problems with the launch of the camera

@shavanni @albelTW

 

Which device you have? As I have checked in my Z1C v5.1.1 the way you have mentioned but it didn't happened in my phone and my camera is working normally. I suggest you to clear data and cache from camera app through settings-apps-all-camera. 

Highlighted
Adept
Message 10 of 12
2,843 Views
Message 10 of 12

Re: problems with the launch of the camera

Z1 Compact

 

The clearing of the app data and cache is only a temporary solution. As soon as you take 2 or more photos, the problem reoccurs

 

 

I looked in the z1 forum and found a solution

 

After the 5.1.1 update, a setting in the Developer options was activated.

By turning off Use AwesomePlayer as resolved the issue