account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Xperia Z2 magnetic charging problem

Highlighted
Adviser
Message 11 of 19
3,224 Views
Message 11 of 19

Re: Xperia Z2 magnetic charging problem

I'm having the same problem with my Z2 phone and Tablet. The phone has been changed with a new one by Sony but after 3 week the prblem start again.

Now every time the problem is present I have to hard reset the phone/tablet for 2/3 times then connect directly to the USB port to start charging normally.

This problem is never püresented with my Z3 phone, so I think is a software related prblem of the Z2 line.

Highlighted
Enthusiast
Message 12 of 19
3,206 Views
Message 12 of 19

Re: Xperia Z2 magnetic charging problem

I had this problem when connecting to usb 2.0. Try 3.0 ( if charge from PC), If use puwer supply, try connect dock with phones charger and cable.worked for me.
Highlighted
Rookie
Message 13 of 19
2,950 Views
Message 13 of 19

Re: Xperia Z2 magnetic charging problem

Another forum naming "Lollipop charging bug" addressing the same problem. please check it as well. 

Highlighted
Enthusiast
Message 14 of 19
2,942 Views
Message 14 of 19

Re: Xperia Z2 magnetic charging problem

Connect charging dock with phones original charger and cable, should work. It flashing because it needs more power. If charge from PC try 3.0 USB, or those what is in PC back.

Highlighted
Learner
Message 15 of 19
2,621 Views
Message 15 of 19

Re: Xperia Z2 magnetic charging problem

I had the same problem on my Z1s phone. I think the problem was that one time i connected "inverted" the magnetic charger and because the charger had polarity, maybe some diode or other electronic component broke.
Could be this possible?
Someone could solve this problem?

Tks! 

RamaMollo

Highlighted
Message 16 of 19
2,530 Views
Message 16 of 19

Re: Xperia Z2 magnetic charging problem

Im have the Same problem today it only charge to 90% and the dockingstation smells like it is burnt inside
Highlighted
Rookie
Message 17 of 19
2,245 Views
Message 17 of 19

Re: Xperia Z2 magnetic charging problem

I had the same problem also it would blink connected then disconnected with the USB and never charged past 80% on usb. I could never get the magnetic part to work but a factory reset and using only very tight fitting USB allowed me to charge it to 80% with the USB.
Highlighted
Message 18 of 19
1,681 Views
Message 18 of 19

Re: Xperia Z2 magnetic charging problem

I have same problem Slightly frowning Face I can't charge my Xperia after 94%...

What I have to do? it's software problem? or may phone is damaged?

One time poster
Message 19 of 19
1,104 Views
Message 19 of 19

Re: Xperia Z2 magnetic charging problem

The dokcing station worked fine in the first 2-3 weeks without this problem and the next test for me was to turn te smartphone off and try to charge it the result was : https://www.youtube.com/watch?v=rem9Oi4Wiiw

4-5 seconds charging this time with powerbutton and volume button option and in the first video it was from second to second with the charge (blink) problem