account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

USB transfer unreliable (Xperia Z5P)

Highlighted
Adviser
Message 1 of 10
996 Views
Message 1 of 10

USB transfer unreliable (Xperia Z5P)

1) when I plug the phone into my Windows PC (10), the phone will show "Use USB for" and I select "Transfer files (MTP)".

However, quickly afterward the same dialog will pop up

 

2) When I am lucky - and MTP works - I'll navigate through the folders on my 64GB uSD card in my phone and suddenly the phone stops sending the data. Maybe USB will have worked for 30secs.

 

3) When I reboot the phone, then I can reliably get MTP to work and I can copy files.

 

What can I do to get file transfer to work reliably without having to reboot my phone ? (I would expect this from a cheap phone)

 

device-2016-12-27-172414.png

9 REPLIES 9
Highlighted
Forum Legend
Message 2 of 10
981 Views
Message 2 of 10

Re: USB transfer unreliable (Xperia Z5P)

does it indicate that the connection is stopped? (like the ding sound)

 

try to secure your usb port at the phone's end,. it might be loose.

 

does this happen when you are on safe mode?


---------------------------------------------------------------------------
Learn to take care and troubleshoot your Device here:
Xperia Support by Sony: https://support.sonymobile.com/global-en/
Highlighted
Sony Xperia Support
Message 3 of 10
970 Views
Message 3 of 10

Re: USB transfer unreliable (Xperia Z5P)

Hi @_AlBi_,

 

Welcome to the community.

 

Based on the information you have provided it sounds like the connection is getting interrupted. In addition to the suggestions @nolramlb has provided, I also recommend you try another USB cable, another USB port in your PC, and if possible, another PC to see if the same things are happening. It will help us isolate where the problem originates.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Highlighted
Adviser
Message 4 of 10
954 Views
Message 4 of 10

Re: USB transfer unreliable (Xperia Z5P)

Hi nolramlb,

I had a USB cable (a long one) and when I plugged it in, my Z5 gave a lot of dinging sounds. So I replaced it.

 

I then used another USB cable. However, I noticed last night that the transfers failed after a little bit of time.

 

I tried fiddling with the cable, slightly pushing it around the connector, to see if it was lose. The phone didn't lose connection though. It seems like a solid connection.

 

I haven't tried booting into safe mode. I simply rebooted the phone and after the reboot I was able to connect without issue and transfer a 1GB file.

Adviser
Message 5 of 10
953 Views
Message 5 of 10

Re: USB transfer unreliable (Xperia Z5P)

Hi CameronT,

 

I'll try another USB cable and the USB ports on the other side of my laptop, the next time I run into this problem.

Highlighted
Sony Xperia Support
Message 6 of 10
946 Views
Message 6 of 10

Re: USB transfer unreliable (Xperia Z5P)

@_AlBi_,

 

Let me know how you got on.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Highlighted
Scavenger Hunt Winner
Message 7 of 10
941 Views
Message 7 of 10

Re: USB transfer unreliable (Xperia Z5P)

Make sure the phone doesn't lock itself while connected
//----------------- C:\》$ Path- Thyme: .trawler //-----------------Auto-Correct Disclaimer: Not sorry. //----------------- Batteries not included.
Highlighted
Adviser
Message 8 of 10
837 Views
Message 8 of 10

Re: USB transfer unreliable (Xperia Z5P)

I suspect two things:

 

1) when I want to copy files to my phone *and* I have Android Studio running, the probability of successfully accessing the SDcard is reduced.

2) attaching the USB cable between phone and computer, whilst the phone is locked, results in increased probability that accessing the SDcard will fail (obviously after unlocking the phone whilst the cable is still connected - and selecting MTP)

 

USB cable itself is known working. I have seen a faulty USB cable trigger the "Use USB for" dialog repeatedly. My problem description is not that problem.

Highlighted
Scavenger Hunt Winner
Message 9 of 10
827 Views
Message 9 of 10

Re: USB transfer unreliable (Xperia Z5P)

I transfer 2GB+ files on a daily basis, because I do things like this 

Screenshot_20170204-065425.png


What does windows 10 see the phone as in device manager?

//----------------- C:\》$ Path- Thyme: .trawler //-----------------Auto-Correct Disclaimer: Not sorry. //----------------- Batteries not included.
Highlighted
One time poster
Message 10 of 10
681 Views
Message 10 of 10

Re: USB transfer unreliable (Xperia Z5P)

I am having the same issue (as OP).
Cannot transfer files, as the device randomly disconnects mid-transfer. Seems to happen more when I am navigating file tree or transferring multiple folders, but no exclusively in those conditions.

Now I cannot view all the files on my external SD. I cannot connect to transfer files at all (the dialogue to connect comes up automatically every few seconds now).

 

Sony Xperia Z5 Compact E5823

Build: 32.3.A.2.33 (has been the same on various previous builds since I've had the phone, usable before, this version is worse).

 

I have tried:
-Several different cables

-Multiple ports (usb3.0 and usb 2.0)

-Changed settings from developer options (usb debugging off/on, switching from usb configuration options)

-I've tried via Linux and Windows 7, and Window 8 on a virtual machine

-In Linux I've tried using jmtpfs, mtpfs, several other apps, vlc, clementine, ... every time I click on the device's icon, the dialogue pops up on the Z5C again and it doesn't connect.

-Restarted phone, restarted computer, double checked the versions (updated computer).

 

From the Linux terminal:

[~] sudo jmtpfs /media/xperiaz5c                                               

Device 0 (VID=0fce and PID=51da) is a SONY XPeria Z5 Compact MTP+ADB.
ignoring libusb_claim_interface() = -6PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
ignoring libusb_claim_interface() = -6LIBMTP PANIC: failed to open session on second attempt
terminate called after throwing an instance of 'MtpErrorCantOpenDevice'
  what():  Can't open device
[1]    8170 abort (core dumped)  sudo jmtpfs /media/xperiaz5c
[~] sudo mtp-detect                                                            
libmtp version: 1.1.12

Listing raw device(s)
Device 0 (VID=0fce and PID=51da) is a SONY XPeria Z5 Compact MTP+ADB.
   Found 1 device(s):
   SONY: XPeria Z5 Compact MTP+ADB (0fce:51da) @ bus 3, dev 33
Attempting to connect device(s)
ignoring libusb_claim_interface() = -6PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
ignoring libusb_claim_interface() = -6LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0
OK.