account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Bluetooth now playing info from Wimp missing on Z3

SOLVED
Highlighted
Visitor
Message 11 of 27
829 Views
Message 11 of 27

Re: Bluetooth now playing info from Wimp missing on Z3

I have the same problem.. And it was totally fine with me note2 before.
Tried using other app to play songs in my z3.. Still the same..
Support team.. Pls kindly look into it and fix the bugs
Highlighted
Sony Xperia Support
Message 12 of 27
810 Views
Message 12 of 27

Re: Bluetooth now playing info from Wimp missing on Z3

This has been investigated and it has to do with how the car unit requests information. It makes another request instead of querying for music info which is why you don't see the information in your car. We are working together with Sony car audio division to solve this but at the moment i don't have any information on when a fix will be available and if it will come as an update for the phone or car unit.

For those of you who have this issue with Mazda, please contact Mazda to make sure that your car unit has the latest software and that Z3 is a compatible phone.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Highlighted
One time poster
Message 13 of 27
792 Views
Message 13 of 27

Re: Bluetooth now playing info from Wimp missing on Z3

I am having the same problem. 

It worked before I got the 4.4.4 update.

 

My Telephone is Xperia Z2 and my Head Unit in my car is a Sony XAV602-BT.

 

I have tried with both Spotify and Google Music. Google music worked fine before(except not showing perfect track time.)

Highlighted
Sony Xperia Support
Message 14 of 27
811 Views
Message 14 of 27

Re: Bluetooth now playing info from Wimp missing on Z3

Sorry to hear that you also have this issue.

 

Yes, it seems the same thing also happens with Z2 and some other devices. Right now i can only advise that you wait for a new update for the unit in the car and/or the phone.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Highlighted
One time poster
Message 15 of 27
764 Views
Message 15 of 27

Re: Bluetooth now playing info from Wimp missing on Z3

I also have the same problem, Z3 Compact + Mazda6 2014. With my old Xperia T everythink worked flawlessly...

Highlighted
Learner
Message 16 of 27
740 Views
Message 16 of 27

Re: Bluetooth now playing info from Wimp missing on Z3

I have the same problem with my 2014 Mazda 6 and the experia Z3 compact. I also can;t start the music playing from the mazda audio controls, I have to start it on the phone and then can only change track. Occassionally the track info appears for the first track but then never updates. Very disappointing for a new car and a new phone!

Highlighted
Regular
Message 17 of 27
701 Views
Message 17 of 27

Re: Bluetooth now playing info from Wimp missing on Z3

Problem solved :-)

 

After the major Z3 update end of 2014 the issue is resolved - at least for my Mazda CX-5. The bluetooth audio connection now works flawlessly, with all track, album and artist info showing in the display. Thanks, Sony !

 

 

Highlighted
Sony Xperia Support
Message 18 of 27
673 Views
Message 18 of 27

Re: Bluetooth now playing info from Wimp missing on Z3

Glad to hear that it works now Slightly smiling Face

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Highlighted
One time poster
Message 19 of 27
648 Views
Message 19 of 27

Re: Bluetooth now playing info from Wimp missing on Z3

Hello Richard!

 

I have been experiencing this issue with my New Sony XAV 712BT Headunit and my Sony Xperia Z3 

I have updated to the lastest firmware available for the Headunit and the phone has Android 4.4.4 with no update in the update center.

 

I actually purchased the phone because I thought that the headunit wouldn't support my custom rom on my Samsung Galaxy s4.

However I've since found that stock android on a Galaxy s4 works fine with track info but not with my Xperia Z3 

 

Will this be patched in the latest Android update?

P.S. I am in Australia.

Highlighted
Sony Xperia Support
Message 20 of 27
639 Views
Message 20 of 27

Re: Bluetooth now playing info from Wimp missing on Z3

Sorry to hear that you have this issue as well.

 

I checked the IMEI you have registered with us and i'm afraid the latest software update is not available for your unit yet. Before we can release an update we need local and operator approvals which means that all devices doesn't get the update at the same time.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.