account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

xperia z gyroscope problem

One time poster
Message 1 of 38
44,398 Views
Message 1 of 38

xperia z gyroscope problem

Hi.please i need help.since the last update to 4.3 my gyroscope and proximity sensor are not working anymore.so the auto rotation and all games and apps that depends on gyroscope are useless.i have done the repair process on pc companion but still not working.note that there is no protective cover over the prox.sensor.
37 REPLIES 37
One time poster
Message 2 of 38
44,314 Views
Message 2 of 38

Re: xperia z gyroscope problem

Same here w/ my Xperia z, after switching to jb 4.3 I discover my gyroscope is totally idle at any point but my other sensors are still at ease, we need a fast response for this for being a loyal fan of Sony prod.

Thnks
Forum Legend
Message 3 of 38
44,300 Views
Message 3 of 38

Re: xperia z gyroscope problem

Hey there.

 

It's working perfectly fine on my phone running 4.3

 

Lol you put your username as gyroscope. Ok do this to check if your sensor is normal or not.

Download this app https://play.google.com/store/apps/details?id=com.sonymobile.androidapp.functiontester and test all the sensors using it.

 

Or you can try it like this > dial *#*#7378423#*#* in phonepad/ dialpad > service tests > gyroscope > see if the values change if you shake your phone.

 

 

eljay Try a software repair to see if that helps you with the problem


Backup everything as it will erase all data on phone (sms, contacts,apps)
Update/Repair your phone via SUS

SUS ( Sony Update Service) ... download and install it on pc and follow the on-screen instructions

http://www.sonymobile.com/global-en/tools/update-service/

 

_______________________________________________________________________
Discussion guidelines.
Message me or any other moderator to seek help regarding moderation.

One time poster
Message 4 of 38
44,060 Views
Message 4 of 38

Re: xperia z gyroscope problem

Hi everybody.since i have updated my xperia z to 4.3 thr gyroscope and the proximity sensors are not working anymore.i have tried the repair process using pc companion and sus but the problem persists.note that i am using the sony cable.please help
Commissioner
Message 5 of 38
43,966 Views
Message 5 of 38

Re: xperia z gyroscope problem

Yes its happening in 101 only. so its not software issue. As i triedthe same in previous version.i didnt had that problem. to test . just use photosphere app from google. check  if you can align to it accordingly

Xperia ZL C6502 (Replaced with a Perfect Phone)
One time poster
Message 6 of 38
43,947 Views
Message 6 of 38

Re: xperia z gyroscope problem

After putting the*#*#7378423#*#* and recalibration gyro is now working properly
One time poster
Message 7 of 38
43,702 Views
Message 7 of 38

Re: xperia z gyroscope problem

Okay - it's a little late for me to join the party - however - "me too"!!

 

I've googled and better googled this, and found that there are similar problems with other Android devices (Nexus 7 particularly) - but thought I must be the only one with this issue on my trusty Xperia Z.

 

HOWEVER

 

Mine won't even calibrate!!

 

Gyroscope calibration - "FAILED! Please retry with following a product instruction - Error code = -1"

Accel calibration - "FAILED! Please retry with following a product instruction - Error code = -1"

Proximity calibration - FAILED! Please retry or your phone may not support this function - Error code = -98"

 

Further info - worked fine on the latest firmware - 10.4.1.B.0.101 for a few months - decided to wipe and re-install as phone was running sluggish (due to amount of installed junk!!) - after the re-install, this is what I get.

 

Other sensor apps say "waiting for device" on the sensors.

 

So - having previously run custom ROMs on other devices, decided to have a look at the system logs.

 

E/cal_data_manager(27964): Self-Test:ERR-Failed to enable accel
E/cal_data_manager(27964): Self-Test:ERR-Failed to enable gyro
E/cal_data_manager(27964): Self-Test:ERR-Failed to enable compass

 

A whole bunch of:

 

E/Sensors ( 851): HAL: ERR open file " " to read with error 2  (I added the quotes here for ease of reading)
E/Sensors ( 851): HAL:ERR can't read chip_enable

 

and....

 

E/Sensors (  774): HAL:unknown compass id ©@@ÉÄDr@/─p☻ -- params default to ak8975 and might be wrong.

 

(this is just using USB debugging, and looking at logcat)

 

Re-installation of firmware has NOT fixed the issue, and the device will NOT re-calibrate.  From the research I've done, and from the info I've read - it's because a small part of the filesystem (which is used to reference the sensors) is now corrupted - so it doesn't know what the sensors (or WHERE the sensors) are at.

 

So what IS wrong?  How do we fix?  With full access to the filesystem (i.e. root) I'm confident it'd be doable, but my linux knowledge lies more with basic admin than something like this!

 

Can I also please urge anyone with this, or who has previously had this, to comment, or at least 'me too' the post?  I suspect it's probably wider-spread than we'd think...

 

Slightly smiling Face

 

Highlighted
Message 8 of 38
42,533 Views
Message 8 of 38

Re: xperia z gyroscope problem

Last week, all my sensors were still working, but this week, possibly after an update to Android 4.4.4, my gyroscope and proximity sensor are not working on my Sony Xperia Z1 Compact.

 

I dialed *#*#7378423#*#* and went to the Gyroscope service test, the one with the green cube. There I can confirm that my gyroscope is not working, everthing stays zero. However, I do not see any 'calibrate' button. Am I looking in the right menu? How can I recalibrate my gyroscope?

One time poster
Message 9 of 38
42,303 Views
Message 9 of 38

Re: xperia z gyroscope problem

after updating the phone to jelly bean last time the gyro, accelerometer, compass all have stopped working. i have downloaded the function tester. And NO it still does not work.

Went into the service menu to test. Did NOt work also.
tried backup and factory reset via PC Companion. Still NO GO.

Updated to the new Kit Kat. STILL NO GO. FYI NO GO means the gyroscope, accellerometer and compass is not working after applying fix. All this happened during my phone is still withing the warranty period. Although I did report the issue in March 25 2014. i have a service request number 1-1151375485. honestly there have been several cases in which your support team is still unable to provide a fix in relation to this issue.

==================================================
Here is one of the link and the details given prior to the issue is well put. Such a shame to SONY.
https://talk.sonymobile.com/t5/Xperia-Z-ZL-ZR/xperia-z-gyroscope-problem/td-p/559629.

HERE IS THE ISSUE COPIED FROM THE USER's WRITINGS:
Re: xperia z gyroscope problem
Options
May

Okay - it's a little late for me to join the party - however - "me too"!!

I've googled and better googled this, and found that there are similar problems with other Android devices (Nexus 7 particularly) - but thought I must be the only one with this issue on my trusty Xperia Z.

HOWEVER

Mine won't even calibrate!!

Gyroscope calibration - "FAILED! Please retry with following a product instruction - Error code = -1"
Accel calibration - "FAILED! Please retry with following a product instruction - Error code = -1"
Proximity calibration - FAILED! Please retry or your phone may not support this function - Error code = -98"

Further info - worked fine on the latest firmware - 10.4.1.B.0.101 for a few months - decided to wipe and re-install as phone was running sluggish (due to amount of installed junk!!) - after the re-install, this is what I get.

Other sensor apps say "waiting for device" on the sensors.

So - having previously run custom ROMs on other devices, decided to have a look at the system logs.

E/cal_data_manager(27964): Self-Test:ERR-Failed to enable accel
E/cal_data_manager(27964): Self-Test:ERR-Failed to enable gyro
E/cal_data_manager(27964): Self-Test:ERR-Failed to enable compass

A whole bunch of:

E/Sensors ( 851): HAL: ERR open file " " to read with error 2 (I added the quotes here for ease of reading)
E/Sensors ( 851): HAL:ERR can't read chip_enable

and....

E/Sensors ( 774): HAL:unknown compass id ©@@ÉÄDr@/─p☻ -- params default to ak8975 and might be wrong.

(this is just using USB debugging, and looking at logcat)

Re-installation of firmware has NOT fixed the issue, and the device will NOT re-calibrate. From the research I've done, and from the info I've read - it's because a small part of the filesystem (which is used to reference the sensors) is now corrupted - so it doesn't know what the sensors (or WHERE the sensors) are at.

So what IS wrong? How do we fix? With full access to the filesystem (i.e. root) I'm confident it'd be doable, but my linux knowledge lies more with basic admin than something like this!

Can I also please urge anyone with this, or who has previously had this, to comment, or at least 'me too' the post? I suspect it's probably wider-spread than we'd think...
===================================================

My problem is exactly the same. unless SONY provides an explanation or a fix. I have to say. I will do everything in my power to influence people around me (to say the very least) that your product is no good. I mean if we have access to Google then its not a problem to convince people. All the phones problems is being addressed online and most of the fix is provided NOT by your technicians. And I am very dissatisfied with your customer service. Such bad service. Left me hanging because i could not get my phone fix within the warranty period.
This specific phone problem has never been addressed and rectified properly. NOT even your support staff can provide a solution via an internet fix. you can Google it. I mean the 3 main sensor (gyroscope,accelerometer, compass) defect issue is well known and you did not even try to have a fix for it? So yes. I hope that having me wasting my precious time writing this heart-aching dissatisfaction for purchasing the SONY XPERIA Z phone MAC 2013 with an issue that no solution is provided will produce a much better brain fart for you guys to have a fix for me and other people with good customer service. I mean. I will post this on every android community forum with print screen. SO yes. Please adhere to our request. Addressing it as it was your CEO's personal phone and rectifying it if not you should come up with a better solution. So **bleep** YOU SONY FOR MAKING MY LIFE MISERABLE. I have copied this complaint and will definitely post this on android community forum.
Sincerely,
Mokhzane Mohamed Ramly

Message 10 of 38
42,191 Views
Message 10 of 38

Re: xperia z gyroscope problem

I mentioned two weeks ago that I experienced the same problems, but when I a few days later tried it again, it worked out of the blue. I am not sure if another software upgrade had occurred in the meantime, but I didn't do anything manual. Strange business... In any case, it seems to be software-related.