account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

sony bridge for mac RESTORE phone not working after exchange xperia from Sony

SOLVED
Adviser
Message 1 of 10
3,676 Views
Message 1 of 10

sony bridge for mac RESTORE phone not working after exchange xperia from Sony

Hi everyone,

I have been sent an exchange unit from Sony to replace my previous xperia z

This phone has an older imei number than mine and wont allow me to restore using the Sony Bridge for Mac software

Is this because of the different imei number???

i have lots of notes, messages stored in a previous backup using the Sony bridge for mac software

Which i need to retrieve onto the "second hand Marked and scratched exchange unit" which Sony have sent me

 

DOES anyone have a sollution to this please

 

Thanks in advance...

 

Steve

1 ACCEPTED SOLUTION

Accepted Solutions
Commissioner
Message 4 of 10
4,781 Views
Message 4 of 10

Re: sony bridge for mac RESTORE phone not working after exchange xperia from Sony

Hi Echo_steve

 

Unfortunately, as I expected, you're not able to restore to another phone. However, there is one possible solution, but there is no guarantee it will work and it might mess things upp so you'll have to do it on your own risk. I'm afraid that's the best I can do for now.

 

Here's how to work around the restore block. Again, use this with caution as there's no guarantee it will work. Also make sure Bridge isn't running when you attempt this:

- Do a backup of the new phone
- goto ~/Library/Application Support/Sony Ericsson Bridge for Mac/
- Go to the "Backups" folder and find the backup sets
- Try to locate the old backup folder and rename it to the name of the new backup.

This can be quite tricky, as the folders are named things like "CB5A1JYXNQ". But basically, if the backup set of the old phone is named "ABCDEF01" and the backup set of the new phone is "ABCDEF02", it should be enough to remove (or rename) the new backup set and rename the old one to "ABCDEF02".

Again, I'm sorry there's no easy fix. Please let me know if it works for you.

 

Best Regards,

 

David

View solution in original post

9 REPLIES 9
Commissioner
Message 2 of 10
3,662 Views
Message 2 of 10

Re: sony bridge for mac RESTORE phone not working after exchange xperia from Sony

Hi Echo_steve,

 

Yes, I think that's the problem. Bridge doesn't allow restores between different phone models at least. I will ask the development crew as I'm not sure about the IMEI being a problem.

 

I'll get back to you when I have an answer.

 

Best Regards,

 

David

Adviser
Message 3 of 10
3,651 Views
Message 3 of 10

Re: sony bridge for mac RESTORE phone not working after exchange xperia from Sony

I eagerly await your reply David

It's not a different model just an exchange phone they sent with an older imie number

 

If i had been told that i would loose lots of info with regards to a different imie number i probably would of requested

to have it fixed for the 5th time

 

And as Sony sent a secondhand phone out to me i am concerned that this may be part of the problem

 

I am not happy with Sony at this moment in time as their Service center leaves a lot to be desired

and this just makes matters worse

 

Thanks for your efforts tho...

 

regards Steve...

Commissioner
Message 4 of 10
4,782 Views
Message 4 of 10

Re: sony bridge for mac RESTORE phone not working after exchange xperia from Sony

Hi Echo_steve

 

Unfortunately, as I expected, you're not able to restore to another phone. However, there is one possible solution, but there is no guarantee it will work and it might mess things upp so you'll have to do it on your own risk. I'm afraid that's the best I can do for now.

 

Here's how to work around the restore block. Again, use this with caution as there's no guarantee it will work. Also make sure Bridge isn't running when you attempt this:

- Do a backup of the new phone
- goto ~/Library/Application Support/Sony Ericsson Bridge for Mac/
- Go to the "Backups" folder and find the backup sets
- Try to locate the old backup folder and rename it to the name of the new backup.

This can be quite tricky, as the folders are named things like "CB5A1JYXNQ". But basically, if the backup set of the old phone is named "ABCDEF01" and the backup set of the new phone is "ABCDEF02", it should be enough to remove (or rename) the new backup set and rename the old one to "ABCDEF02".

Again, I'm sorry there's no easy fix. Please let me know if it works for you.

 

Best Regards,

 

David

View solution in original post

Adviser
Message 5 of 10
3,631 Views
Message 5 of 10

Re: sony bridge for mac RESTORE phone not working after exchange xperia from Sony

Already packed the phone away as Sony are sending out another Replacement

BUT took it back out the box to give your method a go
It worked as far as I can tell, didn't have the SIM card in the phone at the time
But I can't see that would make a difference
My notes , messages are back, so should work with the replacement phone when I get it

Your a genius man... Thank you

Kind Regards

Steve...
Commissioner
Message 6 of 10
3,581 Views
Message 6 of 10

Re: sony bridge for mac RESTORE phone not working after exchange xperia from Sony

Hi Echo_steve,

 

I'm happy it worked for you. Just make sure to use this method carefully, and to close Bride before attempting it.

 

My pleasure, if there's anything else regarding Bridge that I can help you with don't hesitate to ask me.

 

Best Regards,

 

David

Learner
Message 7 of 10
3,434 Views
Message 7 of 10

Re: sony bridge for mac RESTORE phone not working after exchange xperia from Sony

Hi,

 

I am using Sony Bridge for Mac and am not able to restore my Contacts and Call Log. Call Logs are not important but Contacts are. On the contrary, Notes and Text Messages are restored from the same backup version. At the time of backup, it showed that backup is successful (I so wish that I had taken the screenshot). I am unable to find out the location of the backup file. Please Help !!! I am using OS X Mavericks.

 

Thanks in anticipation.

Highlighted
Commissioner
Message 8 of 10
3,418 Views
Message 8 of 10

Re: sony bridge for mac RESTORE phone not working after exchange xperia from Sony

Hi DheerajSL,

 

the backups are in ~/Library/"Application Support"/"Sony Ericsson Bridge for Mac"/Backups.

 

Did you try to write that in the terminal? 

 

Do you get an error message or does it just not restore your contacts? 

 

Best Regards,

 

David

One time poster
Message 9 of 10
2,760 Views
Message 9 of 10

Re: sony bridge for mac RESTORE phone not working after exchange xperia from Sony

Hi David.L 


I have that same problem like friend before..
It just not restore my contacts and call log.
I was desperately trying but it just doesn't work..

 

Any advice? Please.


Thanks in anticipation.

 

 

Apprentice
Message 10 of 10
1,673 Views
Message 10 of 10

Re: sony bridge for mac RESTORE phone not working after exchange xperia from Sony

Hello

 

Sadly same issue here. I did a backup last week. Then try to restore it. Phone was the same, os too but it fail.

 

I can see the backup in my "~/Documents/Sony/Backup/" but can't restore it. The only infos I got is on app that can't be restored but that's all. 

 

Can't restore

 

It's in french. But it say that only "com.Slack" can't be restored. I'm using Companion 1.1.24 and 5.1.1 on android. Please help me I've got soo many app preferences that I need to restore.

 

I've try to move the backup to windows but the format is different (not a folder but one *.dbk file)