account arrowhead-down arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Xperia Z Won't Turn On Even After Successful Software Repair

One time poster
Message 1 of 2
289 Views
Message 1 of 2

Xperia Z Won't Turn On Even After Successful Software Repair

My phone suddenly stopped turning on and it goes crazy when I plug it in the wall charger, it gives a red charging LED and then a Sony logo, but after that it turns off everything and repeats,

when I plug it in PC, I get a blue LED and my PC detects my phone as 'S1Boot Fastboot'

 

*I have the latest software updates.

 

**I tried every solution I found:

-Holding power button + volume up for 10 seconds - but didn't get any viberation.

-Performing a Software Repair using xperia companion.

 

***I didn't try to remove the back cover anytime!

1 REPLY
Visitor
Message 2 of 2
247 Views
Message 2 of 2

Re: Xperia Z Won't Turn On Even After Successful Software Repair

That red light problem I had it was connections in the back of sony experia z comes on freezes with time and date doesn't scroll put a new lcd in plus the sticky strips are useless someone stuck he's down with gorilla glue


@Basilamazing wrote:

My phone suddenly stopped turning on and it goes crazy when I plug it in the wall charger, it gives a red charging LED and then a Sony logo, but after that it turns off everything and repeats,

when I plug it in PC, I get a blue LED and my PC detects my phone as 'S1Boot Fastboot'

 

*I have the latest software updates.

 

**I tried every solution I found:

-Holding power button + volume up for 10 seconds - but didn't get any viberation.

-Performing a Software Repair using xperia companion.

 

***I didn't try to remove the back cover anytime!