account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Xperia Z - No Sound on Calls

Genius
Message 11 of 75
8,873 Views
Message 11 of 75

Re: Xperia Z - No Sound on Calls

the sim card either connects or it doesn't, there are no audio channels going through there

it is not your sim card

Veteran
Message 12 of 75
8,873 Views
Message 12 of 75

Re: Xperia Z - No Sound on Calls

Sony should really do something with its quality control... The best if move production from china to Japan.

Genius
Message 13 of 75
8,873 Views
Message 13 of 75

Re: Xperia Z - No Sound on Calls

sorry mate but I strongly disagree with this - this is not a fault with the sim card - the sim card works or it doesn't there is no inbetween and the sim does not carry audio it simply connects to carrier network the phone delivers and recieves all the signals, putting anything in there (bits of paper) have the potencial to remain in there and cause a problem

do not do this under any circumstance

One time poster
Message 14 of 75
8,873 Views
Message 14 of 75

Re: Xperia Z - No Sound on Calls

At least it solved my problem.

By the way, I guess you misunderstood my method. It is to make the sim has full contact with the chip in the phone because some sim cards are thinner in thickness. The paper is between the sim and its removable tray. It will be about the same size as the sim and how it is going to be stuck inside?

Genius
Message 15 of 75
8,873 Views
Message 15 of 75

Re: Xperia Z - No Sound on Calls

solved what problem ? it didn't solve sound problem as the sim would not cause a sound problem

Sony Xperia Support
Message 16 of 75
8,873 Views
Message 16 of 75

Re: Xperia Z - No Sound on Calls

First try disabling Settings -> Call settings -> Microphone noise suppression and see if that helps.

If not, try setting the phone to GSM only/WCDMA only under Settings -> More -> Mobile networks -> Network mode. Does the problem occur regardless of which network you use?

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

One time poster
Message 17 of 75
8,874 Views
Message 17 of 75

Re: Xperia Z - No Sound on Calls

I did all those when I had the phone. Nothing worked.

Anyway, the problem is fixed, I returned the phone and got a replacement. Everything works perfectly now, really enjoy this phone. Slightly smiling Face

Thanks to all who tried to help.

Visitor
Message 18 of 75
8,855 Views
Message 18 of 75

Re: Xperia Z - No Sound on Calls

i Have the same problem . All you need to do is yell . Oh and make sure its on speakerphone. Very dissapointed in the phone as a phone

Highlighted
Learner
Message 19 of 75
8,112 Views
Message 19 of 75

Re: Xperia Z - No Sound on Calls

I am having this problem after 8 months of purchase. I have tried the mentioned activities but no use. I am using the sim card from 2 years from xperia s, but never i encountered such problem.

Its getting really dissapointing. No settings is helping

Visitor
Message 20 of 75
7,570 Views
Message 20 of 75

Re: Xperia Z - No Sound on Calls

I had the exact same issue after about 8 months ! I tried fixing it , but after a few weeks it just disappeared and now my phone is working again ( alsmost ) as it should. I'm hoping this problem stays fixed and not pops back up again after my 24 months of warranty .. Which would **bleep**.

New bug I found, I think after the android 4.3 installation, is whenever I pick up a call the phone automatically puts on the speaker .. Time and time again I have to turn OFFthe speaker.

Does anyone know of a possible setting ? Or is this really a software bug?

Thanks !
Tristan