account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Invalid IMEI Number

Highlighted
Apprentice
Message 11 of 20
667 Views
Message 11 of 20

Re: Invalid IMEI Number

ARGH! I'm having the same problem, too. But mine is with the Xperia Z4 Tablet I just bought a couple weeks ago. To make it worse, dialing #06#  and #60# bring up an "Connection problem or Invalid MMI Code" message. When I use the IMEI code from the label on the side of the box, the website gives me an "Invalid IMEI" error message.

So...what's up?

 

(I also have a microSD card issue, but this is more pressing)

 

Thanks!

One time poster
Message 12 of 20
657 Views
Message 12 of 20

Re: Invalid IMEI Number

I also have problem with IMEI on Sony M4 Dual. I enter first IMEI and it is uncorrect, second IMEI is uncorrect too..

One time poster
Message 13 of 20
611 Views
Message 13 of 20

Re: Invalid IMEI Number

I have the same problem
My phone is Z5 premium dual
One time poster
Message 14 of 20
591 Views
Message 14 of 20

Re: Invalid IMEI Number

I have the same problem with my Z5 Premium. I have entered the exact 15 numbers shown and yet it says that the IMEI number is invalid. Is there any way in which this can be fixed.

Visitor
Message 15 of 20
535 Views
Message 15 of 20

Re: Invalid IMEI Number

I also have Invalid IMEI number on my Z4 tablet.  I registered it when new on Sony website but now it is showing as invalid.  I only know this because I went to update the 'Nickname'.  This is a replacement tablet after first one was replaced under warranty

Sony Xperia Support
Message 16 of 20
532 Views
Message 16 of 20

Re: Invalid IMEI Number

@Beltizar1

I checked your account and i do see one Z4 Tablet registered with an IMEI. Not sure if it's the correct one. Send me a private message with the IMEI that should be registered and i'll try from here.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

One time poster
Message 17 of 20
495 Views
Message 17 of 20

Re: Invalid IMEI Number

Im also having this kind of problem. My phone is m5 dual. Pls help. Thanks.

Apprentice
Message 18 of 20
422 Views
Message 18 of 20

Re: Invalid IMEI Number

Absolutely the same with Xperia C4 Dual (E5333), though it let me to register the phone in account

Sony Xperia Support
Message 19 of 20
417 Views
Message 19 of 20

Re: Invalid IMEI Number

@Mick-GISer

Sorry to hear that Slightly frowning Face

 

When i check your account, i see a C4 Dual (E5333) registered properly with IMEI so it looks ok from here. Are you trying to register both IMEI numbers? You should only register the first.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Apprentice
Message 20 of 20
408 Views
Message 20 of 20

Re: Invalid IMEI Number

No, I just tried to register it by Slot1 IMEI and there were no result. I'd made the registration via personal settings in profile then, warrany information and my last OS update version appeared. I think it will be OK to share this info, because other users could be keeping on trying to register by hotkeys on the web site and not adding data manually...