account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Hidden SSID won't connect

SOLVED
Visitor
Message 1 of 6
4,556 Views
Message 1 of 6

Hidden SSID won't connect

Hi all,

When I hide the SSID of my Wifi at home, my XZ disconnects. Anyone any solution?

Regards,

Paul

1 ACCEPTED SOLUTION

Accepted Solutions
Demigod
Message 2 of 6
5,855 Views
Message 2 of 6

Re: Hidden SSID won't connect

First you can change to Hidden SSID in the router settings and then later you have to connect manually by inserting the correct SSID in the phone.The SSID-name must be exact.

It seems that you have connected to the network when it has been a visible network and then selected hidden SSID, and then the phone is disconnecting because of that.

Let me know if this was the case.

5 REPLIES 5
Demigod
Message 2 of 6
5,856 Views
Message 2 of 6

Re: Hidden SSID won't connect

First you can change to Hidden SSID in the router settings and then later you have to connect manually by inserting the correct SSID in the phone.The SSID-name must be exact.

It seems that you have connected to the network when it has been a visible network and then selected hidden SSID, and then the phone is disconnecting because of that.

Let me know if this was the case.

Visitor
Message 3 of 6
4,443 Views
Message 3 of 6

Re: Hidden SSID won't connect

Thanks, Henke,

That did the trick!

I deleted the entry of my visible Wifi network, and set my Wifi network to hidden in my router. Then I added a new network on my Xperia with the SSID and password, and it connected.

Regards,

Paul

Demigod
Message 4 of 6
4,443 Views
Message 4 of 6

Re: Hidden SSID won't connect

I'm glad it all worked out, thank you for sharing the solution!

Visitor
Message 5 of 6
1,688 Views
Message 5 of 6

Re: Hidden SSID won't connect


@Henke wrote:

First you can change to Hidden SSID in the router settings and then later you have to connect manually by inserting the correct SSID in the phone.The SSID-name must be exact.

 

It seems that you have connected to the network when it has been a visible network and then selected hidden SSID, and then the phone is disconnecting because of that.

 

Let me know if this was the case.


Hi, I have this same problem with my Xperia XZ Premium (Model G8142). I can connect when its broadcasting the SSID (Router = Netgear R7000P), but as soon as it's hidden, it disconnects and cannot reconnect, even if the network is forgotten, the SSID is then hidden and then manually entered on the phone.

 

Any ideas on how to get this to connect automatically to the hidden SSID or is it time for a Note 9?


Cheers

J

Highlighted
One time poster
Message 6 of 6
1,186 Views
Message 6 of 6

Re: Hidden SSID won't connect

Try this: 

1) Go to saved networks, find the one you are trying to conect and forget it

2) Go to Add Network, type its name (SSID), choose the security and type in the password.

3) Right Below the password there is a Advanced Options, go ther and search for hidden network, change it to yes.

I worked for me, although there is a waring regarding security since the phone has to send its own signal to be able to find the hidden network....