account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

SOLVED
Talent
Message 1 of 12
2,977 Views
Message 1 of 12

wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

here is a link to a video i took of the behavior. https://www.youtube.com/watch?v=pmrhhNz7AFo

 

after some random time, maybe 10 minutes maybe two hours, any devices connected to the phone hotspot will lose the connection and no device can see the hotspot anymore, even though the phone shows the hotspot as enabled

 

this is the dmesg output when this happens:

 

<3>[  821.076116] wlan: [5345:E Face with stuck-out TongueE ] limDeleteStaContext: 118:  Deleting station: staId = 3, reasonCode = 2
<3>[  821.085966] wlan: [5345:E :SME] csrRoamCheckForLinkStatusChange: 9530: DISASSOCIATION Indication from MAC for session 0
<3>[  821.086099] wlan: [5345:E :SME] csrRoamCheckForLinkStatusChange: 9533: DISASSOCIATION from peer =00:eb:2d:fa:f6:64  reason = 505 status = 505
<3>[  821.091929] wlan: [5345:E Face with stuck-out TongueE ] __limProcessSmeDisassocCnf: 2744: received DISASSOC_CNF for a STA that does not have context, addr= 00:eb:2d:fa:f6:64"

 



 

 

 sometimes, disabling and reenabling the access point on the phone resumes hotspot functionality (other devices see the hotspot and connect to it)

 

other times, what happens is what you see in the video

 

it happens in all versions i have tried on the phone, 4.4 and 5.0

 

 bluetooth disabled, wifi scanning when wifi off disabled, background data queueing disabled

 

 

Uploaded by George Tsiros on 2015-04-26.
1 ACCEPTED SOLUTION

Accepted Solutions
Sony Xperia Support
Message 10 of 12
3,535 Views
Message 10 of 12

Re: wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

Based on what our developers can see in your logs, we believe we have found the cause of the issue you're seeing and it will be fixed in the next software update.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

11 REPLIES 11
Talent
Message 2 of 12
2,966 Views
Message 2 of 12

Re: wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

i have more info

 

since the logfile is too large for this message board

 

here is the link to a pastebin of it: raw text, pastebin site text

 

please put it to good use

Sony Xperia Support
Message 3 of 12
2,960 Views
Message 3 of 12

Re: wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

Sorry to hear that you have issues with using hotspot.

 

It's not something an issue i'm familiar with but i've forwarded your logs internally to see if i can find more information.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Highlighted
Talent
Message 4 of 12
2,956 Views
Message 4 of 12

Re: wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

it is very important to give them ALL the logs i have put here and on pastebin and tell them to contact me for any more info

Talent
Message 5 of 12
2,925 Views
Message 5 of 12

Re: wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

@Rickard update, please. What did the programmers say? Did they see the logs?

Sony Xperia Support
Message 6 of 12
2,922 Views
Message 6 of 12

Re: wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

I don't have any response yet i'm afraid.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Talent
Message 7 of 12
2,912 Views
Message 7 of 12

Re: wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

@Rickard here is a more detailed error dump, please use it to your best knowledge

 

http://pastebin.com/raw.php?i=yYMMmZF0

 

Sony Xperia Support
Message 8 of 12
2,893 Views
Message 8 of 12

Re: wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

Could you please let me know which build number you have, which operator you're using and the customization version you have in your phone? To check customization version, dial *#*#7378423#*#* and select Service info -> Software info.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Talent
Message 9 of 12
2,881 Views
Message 9 of 12

Re: wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

 

 

my operator is wind greece ("WIND GR")

 

1278-9222-R1D

 

 

however: these are not what i was using one month ago.

 

back then i was using the first ever public official release 5.0 for the z ultra, i think it was nordic

 

don't think it matters much, i'm positive whatever caused the problem still exists

 

 

Sony Xperia Support
Message 10 of 12
3,536 Views
Message 10 of 12

Re: wifi hotspot misbehaving (NOT the same as the recent problem appearing only in 5.0)

Based on what our developers can see in your logs, we believe we have found the cause of the issue you're seeing and it will be fixed in the next software update.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.